码迷,mamicode.com
首页 > 其他好文 > 详细

NYOJ题目5---Binary String Matching

时间:2015-03-31 09:12:58      阅读:122      评论:0      收藏:0      [点我收藏+]

标签:

Binary String Matching

时间限制:3000 ms  |  内存限制:65535 KB
难度:3
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 
来源
网络
上传者

naonao

分析:这道题用strstr函数

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    int test,n;
    char a[100],b[1000];
    cin>>test;
    while(test--)
    {
        cin>>a>>b;
        char *p;
        p=b;
        int count=0;
        while(p=strstr(p,a))
        {
            p=p+1;
            count++;
        }

        printf("%d\n",count);

    }
    return 0;
}

贴一下大牛的最优解

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    string a,b;
    int n;
    cin>>n;
    while(n--)
    {
        cin>>a>>b;
        int pos=b.find(a,0);
        int  count=0;
        while(pos!=string::npos)
        {
            count++;
            pos=b.find(a,pos+1);
        }
        printf("%d\n",count);

    }
    return 0;

}



NYOJ题目5---Binary String Matching

标签:

原文地址:http://blog.csdn.net/qq_qingtian/article/details/44757655

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!