码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1398 Square Coins (母函数-整数拆分变形)

时间:2014-04-29 13:38:21      阅读:316      评论:0      收藏:0      [点我收藏+]

标签:hdu   1398   母函数   

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7612    Accepted Submission(s): 5156


Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 
 

Sample Input
2 10 30 0
 

Sample Output
1 4 27
 
题意:火星上的货币有1,4,9,16,25.....2^17这17中面值的硬币,问任意给定一个不大于300的正整数面额,用这些硬币来组成此面额总共有多少种组合种数。
一看题目就确定是母函数问题,1A。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>

using namespace std;

const int MAX = 300;

int ele[18];
int ans[MAX+2],tmp[MAX+2];

void work(){
	int i,j,k;

	memset(ans,0,sizeof(ans));
	memset(tmp,0,sizeof(tmp));

	for(i=0;i<=MAX;++i){
		ans[i]=1;
	}

	for(i=1;i<17;++i){
		for(j=0;j<=MAX;++j){
			for(k=0;k<=MAX && j+k*ele[i]<=MAX;++k){
				tmp[j+k*ele[i]] += ans[j];
			}
		}
		for(j=0;j<=MAX;++j){
			ans[j] = tmp[j];
			tmp[j] = 0;
		}
	}
}

void init(){
	int i;

	for(i=1;i<=17;++i){
		ele[i-1] = i*i;
	}

	work();
}



int main(){
    //freopen("in.txt","r",stdin);
    //(author : CSDN iaccepted)
    init();

	int n;
	while(scanf("%d",&n)!=EOF){
		if(n==0)break;
		printf("%d\n",ans[n]);
	}
    return 0;
}


HDU 1398 Square Coins (母函数-整数拆分变形)

标签:hdu   1398   母函数   

原文地址:http://blog.csdn.net/iaccepted/article/details/24656485

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!