码迷,mamicode.com
首页 > 其他好文 > 详细

AC Me

时间:2015-04-01 09:36:05      阅读:183      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   杭电   算法   编程   

AC Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13566    Accepted Submission(s): 5966


Problem Description
Ignatius is doing his homework now. The teacher gives him some articles and asks him to tell how many times each letter appears.

It‘s really easy, isn‘t it? So come on and AC ME.
 

Input
Each article consists of just one line, and all the letters are in lowercase. You just have to count the number of each letter, so do not pay attention to other characters. The length of article is at most 100000. Process to the end of file.

Note: the problem has multi-cases, and you may use "while(gets(buf)){...}" to process to the end of file.
 

Output
For each article, you have to tell how many times each letter appears. The output format is like "X:N".

Output a blank line after each test case. More details in sample output.
 

Sample Input
hello, this is my first acm contest! work hard for hdu acm.
 

Sample Output
a:1 b:0 c:2 d:0 e:2 f:1 g:0 h:2 i:3 j:0 k:0 l:2 m:2 n:1 o:2 p:0 q:0 r:1 s:4 t:4 u:0 v:0 w:0 x:0 y:1 z:0 a:2 b:0 c:1 d:2 e:0 f:1 g:0 h:2 i:0 j:0 k:1 l:0 m:1 n:0 o:2 p:0 q:0 r:3 s:0 t:0 u:1 v:0 w:1 x:0 y:0 z:0
 

Author
Ignatius.L
 

Source
 

其实特别水,wa多次 究其原因就是c++输入输出流耗时严重。

#include<iostream>
#include<string.h>
using namespace std;
int main()
{
	

	char gq[100001];
	while(gets(gq))
	{
			int ls[27]={0};
		for(int i=0;i<strlen(gq);i++)
		{
			ls[gq[i]-'a']++;
		
		}
		for(int p=0;p<26;p++)
		{
			cout<<char(p+'a')<<":"<<ls[p]<<endl;
		}
		
		printf("\n");
	}
	return 0;
}


 

AC Me

标签:acm   c++   杭电   算法   编程   

原文地址:http://blog.csdn.net/lsgqjh/article/details/44789799

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!