码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 题目1710 Binary Tree Traversals(二叉搜索树)

时间:2015-04-01 09:41:27      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:

Binary Tree Traversals

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3912    Accepted Submission(s): 1741


Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
技术分享
 

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
 

Output
For each test case print a single line specifying the corresponding postorder sequence.
 

Sample Input
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
 

Sample Output
7 4 2 8 9 5 6 3 1
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1707 1512 1714 1175 1044 
 
中序和前序变后序遍历
ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct s
{
	struct s *l,*r;
	int num;
}node,*Node;
Node root;
int n;
int a[3000],b[3000];
Node creat(int *a,int *b,int n)
{
	Node tree;
	for(int i=0;i<n;i++)
	{
		if(a[0]==b[i])
		{
			tree=(Node)calloc(1,sizeof(node));
			tree->num=b[i];
			tree->l=creat(a+1,b,i);
			tree->r=creat(a+i+1,b+i+1,n-i-1);
			return tree;
		}
	}
	return NULL;
}
void houxu(Node cur)
{
	//Node cur=root;
	if(cur!=NULL)
	{
		houxu(cur->l);
		houxu(cur->r);
		if(cur==root)
			printf("%d",cur->num);
		else
			printf("%d ",cur->num);
	}
}
int main()
{
	//Node root;
	root=(Node)calloc(1,sizeof(node));
	while(scanf("%d",&n)!=EOF)
	{
		int i;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		for(i=0;i<n;i++)
			scanf("%d",&b[i]);
		root=creat(a,b,n);
		houxu(root);
		printf("\n");
	}
	//while(1);
}


HDOJ 题目1710 Binary Tree Traversals(二叉搜索树)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/44786317

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!