码迷,mamicode.com
首页 > 其他好文 > 详细

(kmp) poj 2406

时间:2015-04-01 17:12:59      阅读:125      评论:0      收藏:0      [点我收藏+]

标签:

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 35119   Accepted: 14519

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

 
#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
char s[1000010];
int next[1000010];
void getnext()
{
    next[0]=-1;
    for(int i=1,j=-1;s[i];i++)
    {
        while(j!=-1&&s[j+1]!=s[i]) j=next[j];
        if(s[j+1]==s[i]) j++;
        next[i]=j;
    }
}
int main()
{
    while(scanf("%s",s)!=EOF)
    {
        if(s[0]==‘.‘)
            break;
        int len=strlen(s);
        getnext();
        if(len%(len-next[len-1]-1)==0)
            printf("%d\n",len/(len-next[len-1]-1));
        else
            printf("1\n");
    }
    return 0;
}

  

(kmp) poj 2406

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4383841.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!