码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj-3501-Calculation 2-欧拉函数

时间:2015-04-01 22:08:56      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:

Calculation 2

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2451    Accepted Submission(s): 1023


Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 

Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 

Output
For each test case, you should print the sum module 1000000007 in a line.
 

Sample Input
3 4 0
 

Sample Output
0 2 题目大意为:给一个整数n,求所有大于1小于n的数中,与n不是互质的数 的和 例如:n=6,
大于1小于6的数中,与6不是互质的数有2,3,4
其和为9

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
__int64 euler(__int64 x)
{
	__int64 res=x;
	for(__int64 i=2;i<=floor(sqrt(x*1.0));i++)
	{
		if(x%i==0)
		{
			res-=res/i;
			while(x%i==0)
			{
				x/=i;
			} 
		}
	} 
	if(x>1) res-=res/x;
	return res;
}
int main()
{
	__int64 n;
	while(~scanf("%I64d",&n),n)//(1 ≤ N ≤ 1000000000).  输入为何要用64??? 
	{
		__int64 ans=(n*(n-1)/2-n*euler(n)/2)%1000000007;
		printf("%I64d\n",ans);
	} 
	return 0;
}



hdoj-3501-Calculation 2-欧拉函数

标签:

原文地址:http://blog.csdn.net/holyang_1013197377/article/details/44810377

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!