码迷,mamicode.com
首页 > 其他好文 > 详细

(字典树+暴搜) poj 1204

时间:2015-04-02 01:04:32      阅读:204      评论:0      收藏:0      [点我收藏+]

标签:

Word Puzzles
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 9948   Accepted: 3726   Special Judge

Description

Word puzzles are usually simple and very entertaining for all ages. They are so entertaining that Pizza-Hut company started using table covers with word puzzles printed on them, possibly with the intent to minimise their client‘s perception of any possible delay in bringing them their order. 

Even though word puzzles may be entertaining to solve by hand, they may become boring when they get very large. Computers do not yet get bored in solving tasks, therefore we thought you could devise a program to speedup (hopefully!) solution finding in such puzzles. 

The following figure illustrates the PizzaHut puzzle. The names of the pizzas to be found in the puzzle are: MARGARITA, ALEMA, BARBECUE, TROPICAL, SUPREMA, LOUISIANA, CHEESEHAM, EUROPA, HAVAIANA, CAMPONESA. 
技术分享

Your task is to produce a program that given the word puzzle and words to be found in the puzzle, determines, for each word, the position of the first letter and its orientation in the puzzle. 

You can assume that the left upper corner of the puzzle is the origin, (0,0). Furthemore, the orientation of the word is marked clockwise starting with letter A for north (note: there are 8 possible directions in total). 

Input

The first line of input consists of three positive numbers, the number of lines, 0 < L <= 1000, the number of columns, 0 < C <= 1000, and the number of words to be found, 0 < W <= 1000. The following L input lines, each one of size C characters, contain the word puzzle. Then at last the W words are input one per line.

Output

Your program should output, for each word (using the same order as the words were input) a triplet defining the coordinates, line and column, where the first letter of the word appears, followed by a letter indicating the orientation of the word according to the rules define above. Each value in the triplet must be separated by one space only.

Sample Input

20 20 10
QWSPILAATIRAGRAMYKEI
AGTRCLQAXLPOIJLFVBUQ
TQTKAZXVMRWALEMAPKCW
LIEACNKAZXKPOTPIZCEO
FGKLSTCBTROPICALBLBC
JEWHJEEWSMLPOEKORORA
LUPQWRNJOAAGJKMUSJAE
KRQEIOLOAOQPRTVILCBZ
QOPUCAJSPPOUTMTSLPSF
LPOUYTRFGMMLKIUISXSW
WAHCPOIYTGAKLMNAHBVA
EIAKHPLBGSMCLOGNGJML
LDTIKENVCSWQAZUAOEAL
HOPLPGEJKMNUTIIORMNC
LOIUFTGSQACAXMOPBEIO
QOASDHOPEPNBUYUYOBXB
IONIAELOJHSWASMOUTRK
HPOIYTJPLNAQWDRIBITG
LPOINUYMRTEMPTMLMNBO
PAFCOPLHAVAIANALBPFS
MARGARITA
ALEMA
BARBECUE
TROPICAL
SUPREMA
LOUISIANA
CHEESEHAM
EUROPA
HAVAIANA
CAMPONESA

Sample Output

0 15 G
2 11 C
7 18 A
4 8 C
16 13 B
4 15 E
10 3 D
5 1 E
19 7 C
11 11 H

Source

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
int n,m,p;
char s[1010][1010],tt[1010];
int mp[1010][1010],next[1000010][27],cnt,endd[1000010],ansx[1010],ansy[1010];
char ansd[1010];
const int dx[8]={-1,-1,0,1,1,1,0,-1};
const int dy[8]={0,1,1,1,0,-1,-1,-1};
void insertt(int x)
{
    int temp=0,alp;
    scanf("%s",tt);
    for(int i=0;tt[i];i++)
    {
        alp=tt[i]-‘A‘;
        if(!next[temp][alp]) next[temp][alp]=++cnt;
        temp=next[temp][alp];
    }
    endd[temp]=x;
}
void findd(int sx,int sy,int dic)
{
    int temp=0,alp,x=sx,y=sy,e;
    while(next[temp][alp=mp[x][y]])
    {
        temp=next[temp][alp];
        e=endd[temp];
        if(e) ansx[e]=sx,ansy[e]=sy,ansd[e]=dic;
        x=x+dx[dic];
        y=y+dy[dic];
        if(x<0||x>=n||y<0||y>=m)
            return ;
    }
}
int main()
{
    while(scanf("%d%d%d",&n,&m,&p)!=EOF)
    {
        cnt=0;
        for(int i=0;i<n;i++)
            scanf("%s",s[i]);
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                mp[i][j]=s[i][j]-‘A‘;
            }
        }
        for(int i=1;i<=p;i++)
            insertt(i);
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                for(int k=0;k<8;k++)
                    findd(i,j,k);
            }
        }
        for(int i=1;i<=p;i++)
            printf("%d %d %c\n",ansx[i],ansy[i],ansd[i]+‘A‘);
    }
    return 0;
}

  

(字典树+暴搜) poj 1204

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4385676.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!