标签:
Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.
The input is terminated with three 0’s. This test case is not to be processed.
Output
For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.
Sample Input
4 4 5
S.X.
..X.
..XD
….
3 4 5
S.X.
..X.
…D
0 0 0
Sample Output
NO
YES
这是一道基础的DFS搜索题目,通过遍历每一条可能的路径来看是否可以走出迷宫。这里需要注意的是剪枝,首先,可走方格数小于规定的走出迷宫的时间,则一定不可能走出迷宫,其次,就是奇偶性剪枝。这是我做的第一道DFS题目。还有一点需要注意,一旦找到了可走路径,立即停止搜索,否则会超时的。AC代码如下:
#include <cstdio>
#include <iostream>
#include <cstdlib>
using namespace std;
char map[9][9];
int n,m,t,di,dj;
int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};//四种走法保存在数组中
bool escape=0;//记录是否走出迷宫
void dfs(int si,int sj,int cnt)
{
int i,temp;
if (si>n||sj>m||si<=0||sj<=0)//看是否出界
return;
if (cnt==t&&si==di&&sj==dj)//看是否逃出
{
escape=true;
return;
}
temp=(t-cnt)-abs(si-di)-abs(sj-dj);//奇偶性剪枝
if (temp<0||temp&1)//当目前位置到出口的最少步数大于剩余时间,或者他们的差为奇数时(奇偶性剪枝),直接说明该路径走不通
return;
for (int i=0;i<4;i++)//遍历所有路径
{
if (map[si+dir[i][0]][sj+dir[i][1]]!=‘X‘)
{
map[si+dir[i][0]][sj+dir[i][1]]=‘X‘;//避免重复
dfs(si+dir[i][0],sj+dir[i][1],cnt+1);
map[si+dir[i][0]][sj+dir[i][1]]=‘.‘;//恢复初始状态
if (escape)
return;//此处是关键,如果找到了,就不用再找了,否则会超时的
}
}
return;
}
int main()
{
int si,sj;
while (cin >> n >> m >> t)
{
if (n==0&&m==0&&t==0)
break;
int wall=0;
for (int i=1;i<=n;i++)
{
for (int j=1;j<=m;j++)
{
cin >> map[i][j];
if (map[i][j]==‘S‘)
{
si=i;
sj=j;
}
else
{
if (map[i][j]==‘D‘)
{
di=i;
dj=j;
}
else
{
if (map[i][j]==‘X‘)
wall++;
}
}
}
}
if (n*m-wall<=t)//注意这里的等号
{
cout << "NO" << endl;
continue;
}
escape=false;
map[si][sj]=‘X‘;
dfs(si,sj,0);
if (escape)
cout << "YES" << endl;
else
cout << "NO" << endl;
}
return 0;
}
标签:
原文地址:http://blog.csdn.net/baiyansong8796/article/details/44817785