标签:
Common Subsequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25791 Accepted Submission(s): 11432
Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2,
..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length
common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
Source
Recommend
Ignatius | We have carefully selected several similar problems for you:
2577 1074 1158 1080 1078
ac代码
#include<stdio.h>
#include<string.h>
#define max(a,b) (a>b?a:b)
int dp[1010][1010],len1,len2;
char s1[1010],s2[1010];
void LCS()
{
int i,j;
for(i=1;i<=len1;i++)
{
for(j=1;j<=len2;j++)
{
if(s1[i-1]==s2[j-1])
dp[i][j]=dp[i-1][j-1]+1;
else
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
}
}
}
int main()
{
while(scanf("%s%s",&s1,s2)!=EOF)
{
len1=strlen(s1);
len2=strlen(s2);
LCS();
printf("%d\n",dp[len1][len2]);
}
}
HDOJ 题目1159 Common Subsequence(LCS)
标签:
原文地址:http://blog.csdn.net/yu_ch_sh/article/details/44834729