码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU 1042 N!

时间:2015-04-03 01:38:16      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   杭电   算法   编程   

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 61718    Accepted Submission(s): 17632


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
1 2 3
 

Sample Output
1 2 6
 

Author
JGShining(极光炫影)
 一开始 不会做 但最后 终于能理解大数阶乘的算法了!
#include<iostream>
using namespace std;
int main()
{
	int ls[10001];
	int N,i,j;
	while(cin>>N)
	{
		int m=0;ls[0]=1;
		for( i=1;i<=N;i++)
		{
			int temp=0;
			for(j=0;j<=m;j++)
			{
				ls[j]=ls[j]*i+temp;
				temp=ls[j]/10000;
				ls[j]=ls[j]%10000;
			}
			if(temp)
			{
			    ls[++m]=temp;
			}
			
		}
		cout<<ls[m];
			for(int k=m-1;k>=0;k--)
				printf("%04d",ls[k]);
			cout<<endl;
	}
	return 0;
}

杭电 HDU 1042 N!

标签:acm   c++   杭电   算法   编程   

原文地址:http://blog.csdn.net/lsgqjh/article/details/44841165

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!