码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU 2674 N!Again

时间:2015-04-03 09:21:10      阅读:113      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   杭电   算法   编程   

N!Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3871    Accepted Submission(s): 2070


Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven‘s finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!
 

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 

Output
For each case, output N! mod 2009
 

Sample Input
4 5
 

Sample Output
24 120
 

Author
WhereIsHeroFrom
 

Source
 
此题有技巧 否则会超时
#include<iostream>
using namespace std;
int main()

{
	int N;
	while(cin>>N)
	{
		int sum=1;int result=0;
		if(N<2009)
		{
			for(int i=1;i<=N;i++)
			{ 
				sum*=i;
			   sum%=2009;
			}
		    cout<<sum<<endl;
		}
		else
			cout<<0<<endl;

	}
	return 0;
}

杭电 HDU 2674 N!Again

标签:acm   c++   杭电   算法   编程   

原文地址:http://blog.csdn.net/lsgqjh/article/details/44840213

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!