码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 108 - Maximum Sum (简单贪心)

时间:2015-04-03 09:25:36      阅读:210      评论:0      收藏:0      [点我收藏+]

标签:acm   贪心   uva   

UVA - 108

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

技术分享

Background

A problem that is simple to solve in one dimension is often much more difficult to solve in more than one dimension. Consider satisfying a boolean expression in conjunctive normal form in which each conjunct consists of exactly 3 disjuncts. This problem (3-SAT) is NP-complete. The problem 2-SAT is solved quite efficiently, however. In contrast, some problems belong to the same complexity class regardless of the dimensionality of the problem.

The Problem

Given a 2-dimensional array of positive and negative integers, find the sub-rectangle with the largest sum. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. A sub-rectangle is any contiguous sub-array of size 技术分享 or greater located within the whole array. As an example, the maximal sub-rectangle of the array:

技术分享

is in the lower-left-hand corner:

技术分享

and has the sum of 15.

Input and Output

The input consists of an 技术分享 array of integers. The input begins with a single positive integer N on a line by itself indicating the size of the square two dimensional array. This is followed by 技术分享 integers separated by white-space (newlines and spaces). These 技术分享 integers make up the array in row-major order (i.e., all numbers on the first row, left-to-right, then all numbers on the second row, left-to-right, etc.). N may be as large as 100. The numbers in the array will be in the range [-127, 127].

The output is the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7  0 9  2 -6  2
-4  1 -4  1 -1
8  0 -2

Sample Output

15

Source

Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Problem Solving Paradigms :: Dynamic Programming :: Max Sum
Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 4. Algorithm Design
Root :: Competitive Programming: Increasing the Lower Bound of Programming Contests (Steven & Felix Halim) :: Chapter 3. Problem Solving Paradigms :: Dynamic Programming :: Maximum Sum
Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Problem Solving Paradigms :: Dynamic Programming :: Max 2D Range Sum

 Status





AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#define LL long long
#define INF 0xffffffff
using namespace std;

int N;
int a[105][105];
int sum[105][105];

int main() {
	while(scanf("%d", &N) != EOF) {
		for(int i = 1; i <= N; i++) {
			for(int j = 1; j <= N; j++) {
				scanf("%d", &a[i][j]);
			}
		}
		
		memset(sum, 0, sizeof(sum));
		for(int i = 1; i <= N; i++) {
			int t = 0;
			for(int j = 1; j <= N; j++) {
				t += a[i][j];
				sum[i][j] = sum[i - 1][j] + t;
				//printf("%d ", sum[i][j]);
			}
			//printf("%d\n");
		}
		
		int p, q, ans = INF;
		for(int i = 1; i < N; i++) {
			for(int j = 1; j < N; j++) {
				for(int k = i; k <= N; k++) {
					for(int l = j; l <= N; l++) {
						int tmp = sum[k][l] - sum[i-1][l] - sum[k][j-1] + sum[i-1][j-1];
						if(tmp > ans) ans = tmp;
					}
				}
			}
		}
		
		printf("%d\n", ans);
	}
	return 0;
}

















UVA - 108 - Maximum Sum (简单贪心)

标签:acm   贪心   uva   

原文地址:http://blog.csdn.net/u014355480/article/details/44838735

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!