码迷,mamicode.com
首页 > 其他好文 > 详细

【HDU 1693】Eat the Trees

时间:2015-04-03 09:30:26      阅读:110      评论:0      收藏:0      [点我收藏+]

标签:hdu   oi   插头dp   

Eat the Trees

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3004    Accepted Submission(s): 1448


Problem Description
Most of us know that in the game called DotA(Defense of the Ancient), Pudge is a strong hero in the first period of the game. When the game goes to end however, Pudge is not a strong hero any more.
So Pudge’s teammates give him a new assignment—Eat the Trees!

The trees are in a rectangle N * M cells in size and each of the cells either has exactly one tree or has nothing at all. And what Pudge needs to do is to eat all trees that are in the cells.
There are several rules Pudge must follow:
I. Pudge must eat the trees by choosing a circuit and he then will eat all trees that are in the chosen circuit.
II. The cell that does not contain a tree is unreachable, e.g. each of the cells that is through the circuit which Pudge chooses must contain a tree and when the circuit is chosen, the trees which are in the cells on the circuit will disappear.
III. Pudge may choose one or more circuits to eat the trees.

Now Pudge has a question, how many ways are there to eat the trees?
At the picture below three samples are given for N = 6 and M = 3(gray square means no trees in the cell, and the bold black line means the chosen circuit(s))

技术分享

 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains the integer numbers N and M, 1<=N, M<=11. Each of the next N lines contains M numbers (either 0 or 1) separated by a space. Number 0 means a cell which has no trees and number 1 means a cell that has exactly one tree.
 

Output
For each case, you should print the desired number of ways in one line. It is guaranteed, that it does not exceed 263 – 1. Use the format in the sample.
 

Sample Input
2 6 3 1 1 1 1 0 1 1 1 1 1 1 1 1 0 1 1 1 1 2 4 1 1 1 1 1 1 1 1
 

Sample Output
Case 1: There are 3 ways to eat the trees. Case 2: There are 2 ways to eat the trees.
 

Source
 

Recommend
wangye


插头dp入门题。


最简单的插头dp题(其实本题的思路是简化的插头dp思路,并不广泛适用于插头dp的题目)


题解在这里


行与行之间的转移就是______|转移到|______,横线都是一样的,那么直接把上一行的左移一位就是这一行的第一个了。


#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
int n,m,a[20][20];
long long f[20][20][1<<15];
void Plugdp()
{
	f[0][m][0]=1;
	for (int i=1;i<=n;i++)
	{
		for (int j=0;j<(1<<m);j++)
			f[i][0][j<<1]=f[i-1][m][j];
		for (int j=1;j<=m;j++)
			for (int k=0;k<(1<<(m+1));k++)
			{
				int y=1<<j,x=1<<(j-1);
				if (a[i][j])
				{
					if ((k&y)&&(k&x))
						f[i][j][k]=f[i][j-1][k-x-y];
					else if (!(k&x)&&!(k&y))
						f[i][j][k]=f[i][j-1][k+x+y];
					else f[i][j][k]=f[i][j-1][k^x^y]+f[i][j-1][k];
				}
				else
				{
					if (!(k&x)&&!(k&y))
						f[i][j][k]=f[i][j-1][k];
					else f[i][j][k]=0;
				}
			}
	}
	printf("There are %lld ways to eat the trees.\n",f[n][m][0]);
}
int main()
{
	int T;
    scanf("%d",&T);
	for (int i=1;i<=T;i++)
	{
		scanf("%d%d",&n,&m);
		for (int i=1;i<=n;i++)
			for (int j=1;j<=m;j++)
				scanf("%d",&a[i][j]);
		printf("Case %d: ",i);
		Plugdp();
	}
	return 0;
}

技术分享

【HDU 1693】Eat the Trees

标签:hdu   oi   插头dp   

原文地址:http://blog.csdn.net/regina8023/article/details/44836669

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!