标签:hdu1711 number sequence kmp
Number Sequence
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12695 Accepted Submission(s): 5767
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M].
If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate
a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
模板题~
代码:
#include <stdio.h>
#define M 10100
#define N 1000100
int a[N] , b[M] ;
int next[M] ;
void getNext(int m)
{
int i = -1 , j = 0;
next[0] = -1 ;
while(j<m)
{
if(i == -1 || b[i] == b[j])
{
++i,++j;
next[j] = i ;
}
else
{
if(b[i] == b[next[i]])
i = next[next[i]] ;
else
i = next[i] ;
}
}
}
int main()
{
int t ;
scanf("%d",&t) ;
while(t--)
{
int n , m ;
scanf("%d%d",&n,&m);
for(int i = 0 ; i < n ; ++i)
{
scanf("%d",&a[i]) ;
}
for(int i = 0 ; i < m ; ++i)
{
scanf("%d",&b[i]) ;
}
getNext(m) ;
int i=0 , j=0 ;
while(i<n&&j<m)
{
if(j == -1 || a[i] == b[j])
{
++i , ++j ;
}
else
{
j = next[j] ;
}
}
if(j == m)
{
printf("%d\n",i-m+1) ;
}
else
{
puts("-1") ;
}
}
return 0 ;
}
与君共勉hdu 1711 Number Sequence KMP模板题~~~
标签:hdu1711 number sequence kmp
原文地址:http://blog.csdn.net/lionel_d/article/details/44851329