码迷,mamicode.com
首页 > 其他好文 > 详细

poj2104--K-th Number(划分树)

时间:2015-04-03 21:07:26      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:

K-th Number
Time Limit: 20000MS   Memory Limit: 65536K
Total Submissions: 40169   Accepted: 13120
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

 

 

求第k大数,划分树的模板题

 

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
int a[100005] , a_sort[100005] ;
int sum[20][100005] ;
int tree[20][100005] ;
void build(int c,int l,int r) {
    if( l == r ) return ;
    int mid = (l+r)/2 , m = mid-l+1 ;
    int pl = l , pr = mid + 1 , i ;
    for(i = l ; i <= mid ; i++)
        if( tree[c][i] < a_sort[mid] )
            m-- ;
    for(i = l ; i <= r ; i++) {
        if( i == l ) sum[c][i] = 0 ;
        else sum[c][i] = sum[c][i-1] ;
        if( tree[c][i] == a_sort[mid] ) {
            if( m ) {
                m-- ;
                tree[c+1][pl++] = tree[c][i] ;
                sum[c][i]++ ;
            }
            else
                tree[c+1][pr++] = tree[c][i] ;
        }
        else if( tree[c][i] < a_sort[mid] ) {
            tree[c+1][pl++] = tree[c][i] ;
            sum[c][i]++ ;
        }
        else
            tree[c+1][pr++] = tree[c][i] ;
    }
    build(c+1,l,mid) ;
    build(c+1,mid+1,r) ;
}
int query(int c,int l,int r,int ql,int qr,int k) {
    int num1 , num2 ; //num1?[l,ql) num2?[ql,qr]
    int mid = (l+r) / 2 ;
    if( l == r ) return tree[c][l] ;
    if( l == ql ) {
        num1 = 0 ;
        num2 = sum[c][qr] ;
    }
    else {
        num1 = sum[c][ql-1] ;
        num2 = sum[c][qr] - num1 ;
    }
    if( k <= num2 )
        query(c+1,l,mid,l+num1,l+num1+num2-1,k) ;
    else
        query(c+1,mid+1,r,mid+1+(ql-l-num1),mid+1+(qr-l-num1-num2),k-num2);
}
int main() {
    int n , m , l , r , k ;
    int i , j ;
    while( scanf("%d %d", &n, &m) != EOF ) {
        for(i = 1 ; i <= n ; i++) {
            scanf("%d", &a[i]) ;
            tree[0][i] = a_sort[i] = a[i] ;
        }
        sort(a_sort+1,a_sort+n+1) ;
        build(0,1,n) ;
        while( m-- ) {
            scanf("%d %d %d", &l, &r, &k) ;
            printf("%d\n", query(0,1,n,l,r,k) ) ;
        }
    }
    return 0 ;
}

poj2104--K-th Number(划分树)

标签:

原文地址:http://blog.csdn.net/winddreams/article/details/44858947

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!