码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU ACM 1303 Doubles

时间:2015-04-04 09:15:08      阅读:105      评论:0      收藏:0      [点我收藏+]

标签:acm   算法   编程   杭电   c++   

Doubles

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3805    Accepted Submission(s): 2646


Problem Description
As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list
1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.
 

Input
The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.
 

Output
The output will consist of one line per input list, containing a count of the items that are double some other item.
 

Sample Input
1 4 3 2 9 7 18 22 0 2 4 8 10 0 7 5 11 13 1 3 0 -1
 

Sample Output
3 2 0
 

Source
 
用用新学的模版类 呵~~~~~~~~
#include<iostream>
#include<vector>
using namespace std;

int main()
{
	vector<double>ls;
	int n, count=0;
	while(1)
	{
		count=0;
		cin>>n;
		if(n==-1)
			break;
		else
			ls.push_back(n);
	
		while(cin>>n,n)
		ls.push_back(n);
		
		int len=ls.size();
	for(int i=0;i<len;i++)
        for(int j=0;j<len;j++)
			if(ls[i]/ls[j]==2)
				count++;
		cout<<count<<endl;
		ls.clear();
	}
	return 0;
}

 

杭电 HDU ACM 1303 Doubles

标签:acm   算法   编程   杭电   c++   

原文地址:http://blog.csdn.net/lsgqjh/article/details/44860695

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!