码迷,mamicode.com
首页 > 其他好文 > 详细

[HDU 2817]A sequence of numbers-大数

时间:2015-04-04 13:46:05      阅读:155      评论:0      收藏:0      [点我收藏+]

标签:大数

A sequence of numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4041    Accepted Submission(s): 1240


Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
 

Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 

Output
Output one line for each test case, that is, the K-th number module (%) 200907.
 

Sample Input
2 1 2 3 5 1 2 4 5
 

Sample Output
5 16
#include <stdio.h>
#include <string.h>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include<queue>
#include<stack>
using namespace std;
const int MOD=200907;
int main()
{
	int n;
	__int64 a,b,c,k;
    scanf("%d",&n);
    while(n--)
    {
    	scanf("%I64d %I64d %I64d %I64d",&a,&b,&c,&k);
    	if(b-a==c-b)
    	{
    		printf("%I64d\n",(a%MOD+((k-1)%MOD)*((b-a)%MOD))%MOD);
    	}
    	else
    	{
    		__int64 ans=a;
    		__int64 temp=b/a;
    		k--;
    		while(k)
    		{
    			if(k&1)	ans=ans*temp%MOD;
    			temp=temp*temp%MOD;//temp*=temp%MOD  WA 
				k>>=1; 
    		}
    		printf("%I64d\n",ans%MOD);
    	}
    }
	return 0;
}


[HDU 2817]A sequence of numbers-大数

标签:大数

原文地址:http://blog.csdn.net/holyang_1013197377/article/details/44871819

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!