码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU ACM 1339 A Simple Task

时间:2015-04-04 16:47:50      阅读:147      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   杭电   算法   编程   

A Simple Task

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4180    Accepted Submission(s): 2304


Problem Description
Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.


Example

For n = 24, o = 3 and p = 3.


Task

Write a program which for each data set:

reads a positive integer n,

computes the odd integer o and the nonnegative integer p such that n = o2^p,

writes the result.
 

Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
 

Output
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.
 

Sample Input
1 24
 

Sample Output
3 3
 

Source
 一开始 常规暴力,怎么该都超时。百度了一下。教训是,数学一一般都有规律,或技巧可言。
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
	int n,N;
	cin>>N;
	for(int k=0;k<N;k++)
	{
		cin>>n;int count=0;
		while(n%2==0)
		{
			count++;
			n/=2;
		}
		cout<<n<<" "<<count<<endl;
	}
	return 0;
}
	

杭电 HDU ACM 1339 A Simple Task

标签:acm   c++   杭电   算法   编程   

原文地址:http://blog.csdn.net/lsgqjh/article/details/44873631

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!