码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU ACM 1335 Basically Speaking

时间:2015-04-04 16:49:44      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   杭电   编程   算法   

Basically Speaking

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2532    Accepted Submission(s): 959


Problem Description
The Really Neato Calculator Company, Inc. has recently hired your team to help design their Super Neato Model I calculator. As a computer scientist you suggested to the company that it would be neato if this new calculator could convert among number bases. The company thought this was a stupendous idea and has asked your team to come up with the prototype program for doing base conversion. The project manager of the Super Neato Model I calculator has informed you that the calculator will have the following neato features:
It will have a 7-digit display.

Its buttons will include the capital letters A through F in addition to the digits 0 through 9.

It will support bases 2 through 16.
 

Input
The input for your prototype program will consist of one base conversion per line. There will be three numbers per line. The first number will be the number in the base you are converting from. The second number is the base you are converting from. The third number is the base you are converting to. There will be one or more blanks surrounding (on either side of) the numbers. There are several lines of input and your program should continue to read until the end of file is reached.
 

Output
The output will only be the converted number as it would appear on the display of the calculator. The number should be right justified in the 7-digit display. If the number is to large to appear on the display, then print "ERROR‘‘ (without the quotes) right justified in the display.
 

Sample Input
1111000 2 10 1111000 2 16 2102101 3 10 2102101 3 15 12312 4 2 1A 15 2 1234567 10 16 ABCD 16 15
 

Sample Output
120 78 1765 7CA ERROR 11001 12D687 D071
 

Source
 
今天这是咋啦 ,让我跟数值转换过不去了。又一个,注意待转换的数可能有A--Z,所以string了……:
思路是先转换为十进制,然后转换为r进制。
#include<iostream>
#include<string>
#include<math.h>
using namespace std;

int A(string & str,int m)
{
	int x=0,b,t,sum=0;
	int len=str.size()-1;
	while((len+1)>0)
	{
		if(str[len]>='A'&&str[len]<='Z')
		b=str[len]-'A'+10;
		else
		b=str[len]-'0';
		sum+=b*pow(m,x);
		
		x++;
		len--;
		
	}
	
	return sum;
}

void ls(int a,int c)
{
	char x[1000];int t=0;
	while(a)
	{
		int m=a%c;
	    if(m>9)
	      x[t++]=m-10+'A';
		else
		  x[t++]=m+'0';
	     a/=c;

	}
	if(t>7)
		cout<<"  ERROR"<<endl;
	else
	{
		for(int i=0;i<7-t;i++)
			cout<<" ";
		for(int j=t-1;j>=0;j--)
			cout<<x[j];
		cout<<endl;
	}


}
	

		
int main()
{
	int b,c;
	string str;
	while(cin>>str>>b>>c)
	    	ls(A(str,b),c);
	
	return 0;
}

杭电 HDU ACM 1335 Basically Speaking

标签:acm   c++   杭电   编程   算法   

原文地址:http://blog.csdn.net/lsgqjh/article/details/44873171

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!