码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU ACM 1390 Binary Numbers

时间:2015-04-05 09:17:31      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   杭电   算法   编程   

Binary Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3372    Accepted Submission(s): 2026


Problem Description
Given a positive integer n, find the positions of all 1‘s in its binary representation. The position of the least significant bit is 0.


Example

The positions of 1‘s in the binary representation of 13 are 0, 2, 3.


Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1‘s in the binary representation of n,

writes the result.
 

Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
 

Output
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1‘s in the binary representation of the i-th input number.
 

Sample Input
1 13
 

Sample Output
0 2 3
 

Source
 
 
水:
用count记录每次的余数位置如果发现余数是1那么就输出他的位置即可;
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
	int n,t,count;
	cin>>n;
	while(n--)
	{
		count=0;
		cin>>t;int flag=0;
		while(t)
		{

			count++;
			int x=t%2;
			if(x)
			{
				if(flag)
				cout<<" "<<count-1;
				else 
				{
					cout<<count-1;
					flag=1;
				}
			}
			t/=2;
		}
		cout<<endl;
	}
	return 0;
}
	

杭电 HDU ACM 1390 Binary Numbers

标签:acm   c++   杭电   算法   编程   

原文地址:http://blog.csdn.net/lsgqjh/article/details/44874225

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!