码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1775 && zoj 2358 Sum of Factorials

时间:2015-04-05 14:44:43      阅读:161      评论:0      收藏:0      [点我收藏+]

标签:poj   zoj   

Sum of Factorials

Time Limit: 1000MS

Memory Limit: 30000K

Description

John von Neumann, b. Dec. 28, 1903, d. Feb. 8, 1957, was a Hungarian-American mathematician who made important contributions to the foundations of mathematics, logic, quantum physics,meteorology, science, computers, and game theory. He was noted for a phenomenal memory and the speed with which he absorbed ideas and solved problems. In 1925 he received a B.S. diploma in chemical engineering from Zurich Institute and in 1926 a Ph.D. in mathematics from the University of Budapest. His Ph.D. dissertation on set theory was an important contribution to the subject. At the age of 20, von Neumann proposed a new definition of ordinal numbers that was universally adopted. While still in his twenties, he made many contributions in both pure and applied mathematics that established him as a mathematician of unusual depth. His Mathematical Foundations of Quantum Mechanics (1932) built a solid framework for the new scientific discipline. During this time he also proved the mini-max theorem of GAME THEORY. He gradually expanded his work in game theory, and with coauthor Oskar Morgenstern he wrote Theory of Games and Economic Behavior (1944).There are some numbers which can be expressed by the sum of factorials. For example 9,9=1!+2!+3! Dr. von Neumann was very interested in such numbers. So, he gives you a number n, and wants you to tell him whether or not the number can be expressed by the sum of some factorials.Well, it‘s just a piece of cake. For a given n, you‘ll check if there are some xi, and let n equal to Σ1<=i<=txi!. (t >=1 1, xi >= 0, xi = xj iff. i = j). If the answer is yes, say "YES"; otherwise, print out "NO".

Input

You will get several non-negative integer n (n <= 1,000,000) from input file. Each one is in a line by itself.The input is terminated by a line with a negative integer.

Output

For each n, you should print exactly one word ("YES" or "NO") in a single line. No extra spaces are allowed.

Sample Input

9
-1

Sample Output

YES

注意0!=1;

深度优先搜索

参考代码:

#include <iostream>
#include <string.h>
using namespace std;
int a[20];
bool used[20];
void work(){
	a[0]=1;
	int mul=1;
	for (int i=1;a[i-1]<1000000+1;i++){
		mul*=i;
		a[i]=mul;
	}
}
bool DFS(int x,int i){
	if (a[i]==x || x==0)
		return true;
	if (a[i]>x)
		return false;
	for (;i<10;i++){
		if (x-a[i]<0)
			continue;
		if (DFS(x-a[i],i+1))
			return true;
	}
	return false;
}
int main(){
	work();
	int n;
	while (cin>>n&&n>=0){
		if (n==0){
			cout<<"NO"<<endl;
			continue;
		}
		if (DFS(n,0)==true)
			cout<<"YES"<<endl;
		else
			cout<<"NO"<<endl;
	}
	return 0;
}



poj 1775 && zoj 2358 Sum of Factorials

标签:poj   zoj   

原文地址:http://blog.csdn.net/codeforcer/article/details/44886677

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!