码迷,mamicode.com
首页 > 其他好文 > 详细

湖南多校对抗赛3.28 J - Jerry's trouble

时间:2015-04-05 17:32:27      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:c语言

Problem J: Jerry‘s trouble

Time Limit: 10 Sec  Memory Limit: 256 MB
Submit: 96  Solved: 46
[Submit][Status][Web Board]

Description

 Jerry is caught by Tom. He was penned up in one room with a door, which only can be opened by its code. The code is the answer of the sum of the sequence of number written on the door. The type of the sequence of number is

 

But Jerry’s mathematics is poor, help him to escape from the room.

Input

 There are some cases (about 500). For each case, there are two integer numbers n, m describe as above ( 1 <= n < 1 000 000, 1 <= m < 1000).

Output

 For each case, you program will output the answer of the sum of the sequence of number (mod 1e9+7).

Sample Input

4 1
5 1
4 2
5 2
4 3

Sample Output

10
15
30
55
100

HINT

题意:给你一个n和一个m,求1-n每个数的m次方的和;
简单的快速矩阵幂,但是因为没有看清题目要求,输入输出都写成了I64d导致一直PE,改成lld就AC了。
代码如下:
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
long long int q=1e9+7;
long long int mix(long long int a, long long int m)
{
	if(m==0) return 1;
	long long int sum=1;
	while(m)
	{
		if(m%2)
			sum=(sum*a) % q;
		a=(a*a)%q;
		m/=2;
	}
	return sum;
}

int main()
{
	long long int n=0, m=0;
	while(scanf("%lld%I64d", &n, &m)!=EOF)
	{
		long long int ans=0;
		for(int i=1; i<=n; i++)
		{
			ans=(ans+mix(i,m))% q;
		}
		printf("%lld\n", ans);
	}
	return 0;
}


湖南多校对抗赛3.28 J - Jerry's trouble

标签:c语言

原文地址:http://blog.csdn.net/doris1104/article/details/44888969

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!