码迷,mamicode.com
首页 > 其他好文 > 详细

bestcoder#36 1002 哈希

时间:2015-04-05 18:40:05      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:

bestcoder#36 1002 哈希

Gunner

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 726    Accepted Submission(s): 326


Problem Description
Long long ago, there is a gunner whose name is Jack. He likes to go hunting very much. One day he go to the grove. There are n技术分享 birds and n技术分享 trees. The ith技术分享 bird stands on the top of the ith技术分享 tree. The trees stand in straight line from left to the right. Every tree has its height. Jack stands on the left side of the left most tree. When Jack shots a bullet in height H to the right, the bird which stands in the tree with height H技术分享 will falls.
Jack will shot many times, he wants to know how many birds fall during each shot.

a bullet can hit many birds, as long as they stand on the top of the tree with height of H技术分享 .
 

 

Input
There are multiple test cases (about 5), every case gives n,m技术分享 in the first line, n技术分享 indicates there are n技术分享 trees and n技术分享 birds, m技术分享 means Jack will shot m技术分享 times.

In the second line, there are n技术分享 numbers h[1],h[2],h[3],,h[n]技术分享 which describes the height of the trees.

In the third line, there are m numbers q[1],q[2],q[3],,q[m]技术分享 which describes the height of the Jack’s shots.

Please process to the end of file.

[Technical Specification]

1n,m1000000(10技术分享6技术分享)技术分享

1h[i],q[i]1000000000(10技术分享9技术分享)技术分享

All inputs are integers.
 

 

Output
For each q[i]技术分享 , output an integer in a single line indicates the number of birds Jack shot down.
 

 

Sample Input
4 3
1 2 3 4
1
1
4
 

 

Sample Output
1
0
1
Hint
Huge input, fast IO is recommended.
 
技术分享
#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<ctype.h>

using namespace std;

const int maxn=1000100;
const int HM=1000100;

int n,m;
struct Hash
{
    int date;
    int cnt;
    Hash *next;
};
Hash H[maxn];

inline int read()
{
    char c=getchar();
    while(!isdigit(c)) c=getchar();
    int f=c-0;
    while(isdigit(c=getchar())) f=f*10+c-0;
    return f;
}

int h(int x)
{
    return x%HM;
}

void insert(Hash*H,int date)
{
    int key=h(date);
    Hash *pre=&H[key],*p=pre->next;
    while(p!=NULL){
        if(p->date==date){
            p->cnt++;
            return;
        }
        pre=p;
        p=p->next;
    }
    p=(Hash*)malloc(sizeof(Hash));
    pre->next=p;
    p->next=NULL;
    p->date=date;
    p->cnt=1;
}

void find_del_output(Hash*H,int date)
{
    int key=h(date);
    Hash *pre=&H[key],*p=pre->next;
    while(p!=NULL){
        if(p->date==date){
            printf("%d\n",p->cnt);
            pre->next=p->next;///删掉结点
            free(p);
            return;
        }
        pre=p;
        p=p->next;
    }
    puts("0");
}

int main()
{
    while(cin>>n>>m){
        memset(H,0,sizeof(H));
        while(n--){
            int h=read();
            insert(H,h);
        }
        while(m--){
            int q=read();
            find_del_output(H,q);
        }
    }
    return 0;
}
View Code

 

bestcoder#36 1002 哈希

标签:

原文地址:http://www.cnblogs.com/--560/p/4394394.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!