码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3180 Number Game(数学啊 )

时间:2015-04-05 18:54:18      阅读:200      评论:0      收藏:0      [点我收藏+]

标签:数学   zoj   

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3221


Gordon is recently reading about an interesting game. At the beginning of the game, there are three positive numbers written on a blackboard. In each round, you are asked to delete one of these three numbers. And you should write the sum of the remaining two numbers minus one back to the blackboard. For example, there are three numbers, 2, 3 and 10 on the blackboard. If you decide to change the number 3 in this round, you will delete the number 3 first and put the number 11=2+10-1 back to the blackboard. So it would be 2, 10 and 11 on the blackboard then. The target of this game is to reach a given number in the minimal steps.

One day, when Gordon was playing the game, his best friend Mike came in. Mike saw that the numbers on the blackboard were 17, 1967 and 1983, and asked Gordon if he had played this game from the beginning numbers 3, 3 and 3. Since Gordon didn‘t leave a trace on the game, he asked you, a young brilliant programmer, to help them check out if Mike made the right guess.

Input

The first line of the input contains an integer T (T < 200), indicating the number of cases. Each test case consists of a line with six positive integers. The first three are the numbers currently on Gordon‘s blackboard and the last three are the numbers that Mike guessed. It is guaranteed that every number in a game is positive and is less than 1,000,000.

Output

For each test case, you should write a single word in a line. If it is possible to get Gordon‘s numbers from Mike‘s guess, you would give the word "Yes". Otherwise you need to output the word "No".

Sample Input

2
6 10 15 7 13 26
17 1967 1983 3 3 3

Sample Output

No
Yes

Author: GAO, Fei
Contest: The 9th Zhejiang University Programming Contest


题意:

后面三个数能否通过一个规则 变换为前面的三个数字!

规则:

最后三个数中每次可以选择一个数字删掉,添加一个数字为:剩下的两个数字的和减去一!

PS:

我们可以从前面三个数字,逆推回去,只要逆推回去等于 后面三个数字删掉其中一个数字后的情况即可!

代码如下:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
int a[4],b[4];
long long num[100000];
int dp[5][3];
int main()
{
    int n,t;
    cin>>t;
    while(t--)
    {
        for(int i=0; i<3; i++)
            cin>>a[i];
        for(int i=0; i<3; i++)
            cin>>b[i];//b- a

        int flag=1;
        sort(b,b+3);

        dp[0][0]=b[0];
        dp[0][1]=b[1];
        dp[0][2]=b[2];

        //qu0
        dp[1][0]=b[1]+b[2]-1;
        dp[1][1]=b[1];
        dp[1][2]=b[2];

        //qu1
        dp[2][0]=b[0];
        dp[2][1]=b[0]+b[2]-1;
        dp[2][2]=b[2];

        //qu0
        dp[3][0]=b[0];
        dp[3][1]=b[1];
        dp[3][2]=b[0]+b[1]-1;

        for(int i=0; i<4; i++)
            sort(dp[i],dp[i]+3);

        while(1)
        {
            sort(a,a+3);
            for(int j=0; j<4; j++)
            {
                flag=1;
                for(int k=0; k<3; k++)
                {
                    if(dp[j][k]!=a[k])
                        flag=0;
                }
                if(flag)
                    break;
            }

            if(flag==1)//PIPEI
            {
                puts("Yes");
                break;
            }

            if(a[1]+1-a[0]==a[2])//死循环
            {
                puts("No");
                break;
            }
            a[2]=a[1]+1-a[0];
            flag=1;
            for(int j=0; j<3; j++)//负数
            {
                if(a[j]<=0)
                    flag=0;
            }
            if(flag==0)
            {
                puts("No");
                break;
            }
        }
    }
    return 0;
}


ZOJ 3180 Number Game(数学啊 )

标签:数学   zoj   

原文地址:http://blog.csdn.net/u012860063/article/details/44889621

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!