码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1385Minimum Transport Cost(两点间最短spfa+输出字典树最小的路径)

时间:2015-04-05 18:55:33      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:图论   spfa   

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8083    Accepted Submission(s): 2104


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
#include<stdio.h>
#include<queue>
using namespace std;
const int N =105;
const int inf = 999999999;
struct PATH
{
    int k,path[N],dis;
};
int n,mapt[N][N],dis[N],frome[N],b[N];
PATH p[N][N];

bool compare(int x,int y)
{
    int k[2]={0},a[2][N];
    while(frome[x]!=x)
    {
        a[0][k[0]++]=x;  x=frome[x];
    }
    a[1][k[1]++]=x;
    while(frome[y]!=y)
    {
        a[1][k[1]++]=y;  y=frome[y];
    }
    while(k[1]&&k[0])
    {
        k[0]--; k[1]--;
        if(a[0][k[0]]>a[1][k[1]])
            return true;
        else if(a[0][k[0]]<a[1][k[1]])
            return false;
    }
    if(k[0])
        return true;
    return false;
}
void spfa()
{
    queue<int>q;
    int inq[N]={0},s;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        dis[j]=inf,frome[j]=j;
        dis[i]=0;
        q.push(i);
        while(!q.empty())
        {
            s=q.front(); q.pop();
            inq[s]=0;
            for(int j=1;j<=n;j++)
            if(mapt[s][j]!=-1&&j!=s)
            {
                if(dis[j]>dis[s]+mapt[s][j]+b[j])
                {
                    dis[j]=dis[s]+mapt[s][j]+b[j];
                    frome[j]=s;
                    if(!inq[j])
                        inq[j]=1,q.push(j);
                }
                else if(dis[j]==dis[s]+mapt[s][j]+b[j])
                {
                    if(compare(j,s))
                        frome[j]=s;
                }
            }
        }
        for(int j=1;j<=n;j++)
        {
            p[i][j].k=0;
            p[i][j].dis=dis[j];
            if(j!=i)
                p[i][j].dis-=b[j];
            int &k=p[i][j].k;
            if(i!=j) //起点与终点相同时,只输出一个点
            p[i][j].path[k++]=j;
            s=frome[j];
            while(s!=frome[s])
            {
                p[i][j].path[k++]=s; s=frome[s];
            }
            p[i][j].path[k++]=i;
        }
    }
}
int main()
{
    int a,aa;
    while(scanf("%d",&n)>0&&n)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            scanf("%d",&mapt[i][j]);
        for(int i=1;i<=n;i++)
            scanf("%d",&b[i]);
        spfa();
        while(scanf("%d%d",&a,&aa)>0&&a+aa>0)
        {
            printf("From %d to %d :\n",a,aa);
            printf("Path: %d",a);
            int k=p[a][aa].k-1;
            while(k>0)
            {
                k--; printf("-->%d",p[a][aa].path[k]);
            }
            printf("\nTotal cost : %d\n\n",p[a][aa].dis);
        }
    }
}


HDU1385Minimum Transport Cost(两点间最短spfa+输出字典树最小的路径)

标签:图论   spfa   

原文地址:http://blog.csdn.net/u010372095/article/details/44889521

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!