码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU 1570 A C

时间:2015-04-06 15:47:25      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   杭电   算法   编程   

A C

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4206    Accepted Submission(s): 2671


Problem Description
Are you excited when you see the title "AC" ? If the answer is YES , AC it ;

You must learn these two combination formulas in the school . If you have forgotten it , see the picture.

技术分享


Now I will give you n and m , and your task is to calculate the answer .
 

Input
In the first line , there is a integer T indicates the number of test cases.
Then T cases follows in the T lines.
Each case contains a character ‘A‘ or ‘C‘, two integers represent n and m. (1<=n,m<=10)
 

Output
For each case , if the character is ‘A‘ , calculate A(m,n),and if the character is ‘C‘ , calculate C(m,n).
And print the answer in a single line.
 

Sample Input
2 A 10 10 C 4 2
 

Sample Output
3628800 6
 

Author
linle
 

Source
 
 哈尔滨生活也是醉了 ,放个假无聊到 刷这题儿玩儿。
#include<iostream>
using namespace std;
int fac(int k)
{
	int sum=1;
	for(int i=1;i<=k;i++)
		sum*=i;
	return sum;
}

int main()
{
	int n,N,M;
	char ch;
	cin>>n;
	while(n--)
	{
		cin>>ch>>N>>M;
		if(ch=='A')
			cout<<fac(N)/(fac(N-M))<<endl;
		else if(ch=='C')
			cout<<fac(N)/(fac(M)*fac(N-M))<<endl;
	}
	return 0;
}

 

杭电 HDU 1570 A C

标签:acm   c++   杭电   算法   编程   

原文地址:http://blog.csdn.net/lsgqjh/article/details/44901907

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!