码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU ACM 1563 Find your present!

时间:2015-04-06 15:47:44      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   杭电   算法   编程   

Find your present!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3096    Accepted Submission(s): 2051


Problem Description
In the new year party, everybody will get a "special present".Now it‘s your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present‘s card number will be the one that different from all the others.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 

Input
The input file will consist of several cases.  
Each case will be presented by an integer n (1<=n<=200, and n is odd) at first. Following that, n positive integers will be given in a line. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 

Output
For each case, output an integer in a line, which is the card number of your present.
 

Sample Input
5 1 1 3 2 2 3 1 2 1 0
 

Sample Output
3 2
 继续无聊中………… 清明早上竟然 下起了大学 ,天晴那么好 我也真服了东北的气候。网上买了两件衣服感觉还不错^^
明天又该回复上课了!都他妈学不会了
#include<iostream>
using namespace std;
int main()
{
	int n;
	int ls[201];
	while(cin>>n,n)
	{
		int count[201]={0};
		for(int i=0;i<n;i++)
			cin>>ls[i];
		for(int k=0;k<n;k++)
			for(int j=0;j<n;j++)
				if(ls[k]==ls[j])
					count[k]++;
		for(int m=0;m<n;m++)
			if(count[m]==1)
				cout<<ls[m]<<endl;
	}
	return 0;
}

杭电 HDU ACM 1563 Find your present!

标签:acm   c++   杭电   算法   编程   

原文地址:http://blog.csdn.net/lsgqjh/article/details/44901733

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!