码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 2603 Bone Collector(简单01背包)

时间:2015-04-06 15:50:44      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:杭电   hdu2602   杭电2602   

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 35296    Accepted Submission(s): 14531


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
技术分享

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
 
很裸的一道01背包,注意内层for循环(for(int j = v ;j>=weight[i];j--))

AC代码:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std ;

int dp[10000] ;
int value[1005],weight[1005] ;
int t,n,v;

int main()
{
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            scanf("%d%d",&n,&v) ;
            for(int i = 0 ;i<n ;i++)
                scanf("%d",&value[i]) ;
            for(int j = 0 ;j<n ;j++)
                scanf("%d",&weight[j]) ;
            memset(dp,0,sizeof(dp)) ;
            for(int i = 0; i<n ;i++)
            {
                for(int j = v ;j>=weight[i] ;j--)
                {
                    dp[j] = max(dp[j],dp[j-weight[i]]+value[i]) ;
                }
            }
            printf("%d\n",dp[v]) ;
        }
    }
    return 0 ;
}


杭电 2603 Bone Collector(简单01背包)

标签:杭电   hdu2602   杭电2602   

原文地址:http://blog.csdn.net/u012566693/article/details/44901597

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!