码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2639 Bone Collector II

时间:2015-04-06 17:20:44      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2759    Accepted Submission(s): 1428


Problem Description
The title of this problem is familiar,isn‘t it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven‘t seen it before,it doesn‘t matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 231).
 

Sample Input
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
12 2 0

求第K大的总价值

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#define N 10009
using namespace std;

int w[N],c[N],dp[N][33];
int T;
int n,v,k;
int a[N],b[N];

int main()
{
    while(~scanf("%d",&T))
    {
        while(T--)
        {
            scanf("%d %d %d",&n,&v,&k);

            memset(dp,0,sizeof dp);
            //memset(w,0,sizeof w);
           // memset(c,0,sizeof c);
            memset(a,0,sizeof a);
            memset(b,0,sizeof b);

            for(int i=0;i<n;i++)
            scanf("%d",&w[i]);

            for(int i=0;i<n;i++)
            scanf("%d",&c[i]);


            for(int i=0;i<n;i++)
            for(int j=v;j>=c[i];j--)
            {
                for(int t=1;t<=k;t++)
                {
                    a[t]=dp[j][t];
                    b[t]=dp[j-c[i]][t]+w[i];
                }

                int p1=1,p2=1,num=1;
                while(1)
                {
                    if(a[p1]>=b[p2])
                    {
                        dp[j][num]=a[p1];
                        p1++;
                    }
                    else
                    {
                        dp[j][num]=b[p2];
                        p2++;
                    }
                    if(dp[j][num]!=dp[j][num-1])
                    num++;

                    if(num>k || (p1>k&&p2>k))
                    break;
                }

            }
            printf("%d\n",dp[v][k]);
        }
    }
    return 0;
}









hdu 2639 Bone Collector II

标签:

原文地址:http://blog.csdn.net/wust_zjx/article/details/44903109

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!