码迷,mamicode.com
首页 > 其他好文 > 详细

(floyd输出路径) hdu 1385

时间:2015-04-06 21:48:20      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8085    Accepted Submission(s): 2105


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

 

Sample Input
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

 

Sample Output
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
 

 

Source
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
#define INF 100000000
int n,dist[205][205],a[205],path[205][205];
void floyd()
{
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
            path[i][j]=j;
    }
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                int temp=dist[i][k]+dist[k][j]+a[k];
                if(dist[i][j]>temp)
                {
                    dist[i][j]=temp;
                    path[i][j]=path[i][k];
                }
                else if(dist[i][j]==temp&&path[i][k]<path[i][j])
                {
                    path[i][j]=path[i][k];
                }
            }
        }
    }
}
int main()
{
    int u,v;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&dist[i][j]);
                if(dist[i][j]==-1)
                    dist[i][j]=INF;
            }
        }
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        floyd();
        while(scanf("%d%d",&u,&v)!=EOF)
        {
            if(u==-1&&v==-1)
                break;
            printf("From %d to %d :\n",u,v);
            printf("Path: %d",u);
            int temp=u;
            while(u!=v)
            {
                printf("-->%d",path[u][v]);
                u=path[u][v];
            }
            printf("\n");
            printf("Total cost : %d\n\n",dist[temp][v]);
        }
    }
    return 0;
}

  

(floyd输出路径) hdu 1385

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4396634.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!