码迷,mamicode.com
首页 > 其他好文 > 详细

项目三

时间:2014-06-11 11:17:13      阅读:312      评论:0      收藏:0      [点我收藏+]

标签:style   class   blog   code   java   http   

某公司有2栋办公楼,楼内各有2种类型的用户。2栋办公楼之间使用路由器进行互通,楼宇内各使用1块二层交换机把2种类型的用户连接起来。

请你按照下列要求完成公司需求。

1、两栋楼宇内的能够隔离两类人员的广播信息

2、两个楼宇之间能够互通信息(要求使用RIP实现)

所有网络产品均为Cisco

思路:对于每栋楼里的用户使用单臂路由使不同vlan间能够通信,然后运用rip协议是两个路由器相连的网络能够通信.拓扑图:

bubuko.com,布布扣

 

SW1

bubuko.com,布布扣
Switch>enable
Switch#configure terminal
Switch(config)#hostname SW1
SW1(config)#vlan 10
SW1(config-vlan)#name VLAN10
SW1(config-vlan)#exit
SW1(config)#vlan 20
SW1(config-vlan)#name VLAN20
SW1(config-vlan)#exit
SW1(config)#interface FastEthernet0/1
SW1(config-if)#switchport mode trunk
SW1(config-if)#exit
SW1(config)#interface FastEthernet0/2
SW1(config-if)#switchport access vlan 10
SW1(config-if)#exit
SW1(config)#interface FastEthernet0/11
SW1(config-if)#switchport access vlan 20
SW1(config-if)#
bubuko.com,布布扣

R1

bubuko.com,布布扣
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface FastEthernet0/0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#int f0/0.10
R1(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up

R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip add 192.168.1.1 255.255.255.0
R1(config-subif)#exit
R1(config)#int f0/0.20
R1(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up

R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip add 192.168.2.1 255.255.255.0
R1(config-subif)#end

R1#
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface Serial1/0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface Serial1/0, changed state to up
clock rate 9600
R1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up

R1(config-if)#exit
R1(config)#route rip
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.2.0
R1(config-router)#network 10.10.10.0
R1(config-router)#exit

R1(config)#interface Serial1/0
R1(config-if)#ip address 10.10.10.1 255.255.255.0
bubuko.com,布布扣

SW2

bubuko.com,布布扣
Switch>enable
Switch#configure terminal
Switch(config)#hostname SW2
SW2(config)#interface FastEthernet0/1
SW2(config-if)#switchport mode trunk
SW2(config-if)#exit
SW2(config)#vlan 30
SW2(config-vlan)#name VLAN30
SW2(config-vlan)#exit
SW2(config)#vlan 40
SW2(config-vlan)#name VLAN40
SW2(config-vlan)#exit
SW2(config)#interface FastEthernet0/2
SW2(config-if)#switchport access vlan 30
SW2(config-if)#exit
SW2(config)#interface FastEthernet0/11
SW2(config-if)#switchport access vlan 40
bubuko.com,布布扣

R2

bubuko.com,布布扣
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface FastEthernet0/0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#
R2(config-if)#int f0/0.30
R2(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.30, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.30, changed state to up

R2(config-subif)#encapsulation dot1Q 30
R2(config-subif)#ip add 192.168.3.1 255.255.255.0
R2(config-subif)#exit
R2(config)#int f0/0.40
R2(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.40, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.40, changed state to up

R2(config-subif)#encapsulation dot1Q 40
R2(config-subif)#ip add 192.168.4.1 255.255.255.0
R2(config-subif)#end

R2#configure terminal
R2(config)#interface Serial1/0
R2(config-if)#no shutdown
R2(config-if)#clock rate 9600
This command applies only to DCE interfaces
R2(config-if)#
%LINK-5-CHANGED: Interface Serial1/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
R2(config-if)#exit
R2(config)#route rip
R2(config-router)#network 192.168.3.0
R2(config-router)#network 192.168.4.0
R2(config-router)#network 10.10.10.0
R2(config-router)#exit

R2(config)#interface Serial1/0
R2(config-if)#ip address 10.10.10.2 255.255.255.0
bubuko.com,布布扣

pc0 ping pc1,pc2,pc3

bubuko.com,布布扣bubuko.com,布布扣bubuko.com,布布扣

 

项目三,布布扣,bubuko.com

项目三

标签:style   class   blog   code   java   http   

原文地址:http://www.cnblogs.com/jianfengyun/p/3772755.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!