码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2407-Relatives(求一个整数的欧拉函数值)

时间:2015-04-07 09:58:44      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:

Relatives
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

题意:给一个数n,求出不大于n且与n互素的数的个数。

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
const double pi= acos(-1.0);

int Euler(int n)
{
    int m=floor(sqrt(n+0.5));
    int ans=n;
    for(int i=2;i<=m;i++){
        if(n%i==0){
            ans=ans/i*(i-1);
            while(n%i==0){
                n/=i;
            }
        }
    }
    if(n>1)
        ans=ans/n*(n-1);
    return ans;
}
int main()
{
    int n;
    while(~scanf("%d",&n)){
        if(!n) break;
        printf("%d\n",Euler(n));
    }
    return 0;
}


POJ 2407-Relatives(求一个整数的欧拉函数值)

标签:

原文地址:http://blog.csdn.net/u013486414/article/details/44905557

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!