码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 2817 A sequence of numbers(快速幂取模)

时间:2015-04-07 10:02:41      阅读:193      评论:0      收藏:0      [点我收藏+]

标签:acm   算法   c   杭电   

A sequence of numbers

http://acm.hdu.edu.cn/showproblem.php?pid=2817
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4046    Accepted Submission(s): 1242


Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
 

Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 

Output
Output one line for each test case, that is, the K-th number module (%) 200907.
 

Sample Input
2 1 2 3 5 1 2 4 5
 

Sample Output
5 16
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:  2818 2819 2825 2824 2822 

#include<cstdio>

#include<cmath>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
const int MOD=200907;
__int64  fun1(__int64 q,__int64 n)// a1*q^(n-1)//等比数列
{
  __int64 ans=1,base=q;
  while(n)
  {
      if(n&1)
        ans=ans*base%MOD;
        base=base*base%MOD;
        n>>=1;
  }
  return ans%MOD;    
}



__int64 fun2(__int64 a1,__int64 d,__int64 n)//a1+(n-1)*d;
{
    return a1%MOD+((n-1)%MOD*d%MOD)%MOD;
}


int jude(__int64 num1,__int64 num2,__int64 num3)
{
    if(num1+num3==2*num2)
      return 0;
      else
        return 1;
}


int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
     __int64 a1,a2,a3,K;
     scanf("%I64d%I64d%I64d%I64d",&a1,&a2,&a3,&K);
     if(jude(a1,a2,a3))
     {
         __int64 q=a3/a2;
         printf("%I64d\n",(a1%MOD*fun1(q,K-1)%MOD)%MOD);
     }
     else
     {
       __int64 d=a3-a2;
       printf("%I64d\n",fun2(a1,d,K)%MOD); 
     } 
    } 
    return 0;
}

hdoj 2817 A sequence of numbers(快速幂取模)

标签:acm   算法   c   杭电   

原文地址:http://blog.csdn.net/lh__huahuan/article/details/44905125

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!