码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 1162 Eddy's picture(最小生成树)

时间:2015-04-07 10:04:10      阅读:205      评论:0      收藏:0      [点我收藏+]

标签:acm   算法   c   

Eddy‘s picture

http://acm.hdu.edu.cn/showproblem.php?pid=1162
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7521    Accepted Submission(s): 3821


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends ‘s view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. 

Input contains multiple test cases. Process to the end of file.
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. 
 

Sample Input
3 1.0 1.0 2.0 2.0 2.0 4.0
 

Sample Output
3.41
 

Author
eddy
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1301 1233 1102 1217 1142 
 


/**/题意:给定画上n个点,求最短的线段把所有点连起来,简单的最小生成树 


#include<cstdio>

#include<cmath>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
const int M=105; 
int pre[M];
struct node
{
   double start;
   double end;
}island[M];


struct dis
{
    int x;
    int y;
    double value;
}num[M*M];


int find(int x)
{
    int r=x;
    while(pre[r]!=r)
     r=pre[r];
     int i=x,j;
     while(i!=r)
     {
         j=pre[i];
         pre[i]=r;
         i=j;
     }
     return r;
 } 

 
void  merge(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
     pre[fx]=fy;


}


double Dis(node a,node b)//求距离
{
    return sqrt((a.start-b.start)*(a.start-b.start)+(a.end-b.end)*(a.end-b.end)); 
}




int cmp(dis a,dis b)
{
    return a.value<b.value;
}


int main()
{
  int n;
  while(~scanf("%d",&n))
  {
   int i,j,k;


   
    for(i=0;i<=M;i++)
      pre[i]=i;
    
    for(i=1;i<=n;i++)
     scanf("%lf%lf",&island[i].start,&island[i].end);
    if(n==1)//不存在连通
     {
       printf("0.00\n");
       continue;
     }
      k=0;
      memset(num,0,sizeof(num));
      for(i=1;i<=n;i++)
        for(j=i+1;j<=n;j++)
        {
              num[k].value=Dis(island[i],island[j]);
              num[k].x=i;
              num[k].y=j;
              k++;
        }

        
      sort(num,num+k,cmp);

      double ans=0.0;


      for(i=0;i<k;i++)
          if(find(num[i].x)!=find(num[i].y))
          {
            merge(num[i].x,num[i].y);
           ans+=num[i].value;    
        }

    
      int count=0;
      for(i=1;i<=n;i++)
      {
           if(pre[i]==i)
          count++;
          if(count>1)
            break;
      }

      if(count<=1)//count>1 表示不连通
        printf("%.2lf\n",ans);
    
  } 
  return 0;    

hdoj 1162 Eddy's picture(最小生成树)

标签:acm   算法   c   

原文地址:http://blog.csdn.net/lh__huahuan/article/details/44904851

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!