码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4442 贪心

时间:2015-04-07 11:58:07      阅读:116      评论:0      收藏:0      [点我收藏+]

标签:

http://acm.hdu.edu.cn/showproblem.php?pid=4442

Problem Description
WANGPENG is a freshman. He is requested to have a physical examination when entering the university.
Now WANGPENG arrives at the hospital. Er….. There are so many students, and the number is increasing!
There are many examination subjects to do, and there is a queue for every subject. The queues are getting longer as time goes by. Choosing the queue to stand is always a problem. Please help WANGPENG to determine an exam sequence, so that he can finish all the physical examination subjects as early as possible.
 

Input
There are several test cases. Each test case starts with a positive integer n in a line, meaning the number of subjects(queues).
Then n lines follow. The i-th line has a pair of integers (ai, bi) to describe the i-th queue:
1. If WANGPENG follows this queue at time 0, WANGPENG has to wait for ai seconds to finish this subject.
2. As the queue is getting longer, the waiting time will increase bi seconds every second while WANGPENG is not in the queue.
The input ends with n = 0.
For all test cases, 0<n≤100000, 0≤ai,bi<231.
 

Output
For each test case, output one line with an integer: the earliest time (counted by seconds) that WANGPENG can finish all exam subjects. Since WANGPENG is always confused by years, just print the seconds mod 365×24×60×60.
 

Sample Input
5 1 2 2 3 3 4 4 5 5 6 0
 

Sample Output
1419
Hint
In the Sample Input, WANGPENG just follow the given order. He spends 1 second in the first queue, 5 seconds in the 2th queue, 27 seconds in the 3th queue, 169 seconds in the 4th queue, and 1217 seconds in the 5th queue. So the total time is 1419s. WANGPENG has computed all possible orders in his 120-core-parallel head, and decided that this is the optimal choice.
 
/**
hdu 4442  贪心
题目大意:某人去做体检,最初每个体检项目前需要排对x秒,如果选择排其中一个,那么其他队的时间每秒增加y秒,问怎样安排排队的先后能可以使总体的
          排队时间最短
解题思路:假设有两个队伍a和b,如先去排a,则总体等待时间为:ax+ax*by+bx,如先去排b,则总体的等待时间为bx+bx*ay+ax。我们假设a在前优,则:
          ax*by<ay*bx。由此推广到多个队伍,按照ax*by<ay*bx的标准排序后所得的顺序处理即为答案。
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=100005;
typedef long long LL;
const int mod=365*24*60*60;
int n;

struct note
{
    LL x,y;
    bool operator < (const note &other)const
    {
        return x*other.y<other.x*y;
    }
}a[maxn];

int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0)break;
        for(int i=0;i<n;i++)
        {
            scanf("%I64d%I64d",&a[i].x,&a[i].y);
        }
        sort(a,a+n);
        LL maxx=0;
        for(int i=0;i<n;i++)
        {
            maxx=(maxx+a[i].x+maxx*a[i].y)%mod;
        }
        printf("%I64d\n",maxx);
    }
    return 0;
}


hdu 4442 贪心

标签:

原文地址:http://blog.csdn.net/lvshubao1314/article/details/44917589

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!