码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1226 超级密码 BFS 挺不错的题啊!

时间:2015-04-07 21:48:15      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:hdu1226   超级密码   bfs   

超级密码

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2883    Accepted Submission(s): 928


Problem Description
Ignatius花了一个星期的时间终于找到了传说中的宝藏,宝藏被放在一个房间里,房间的门用密码锁起来了,在门旁边的墙上有一些关于密码的提示信息:
密码是一个C进制的数,并且只能由给定的M个数字构成,同时密码是一个给定十进制整数N(0<=N<=5000)的正整数倍(如果存在多个满足条件的数,那么最小的那个就是密码),如果这样的密码存在,那么当你输入它以后门将打开,如果不存在这样的密码......那就把门炸了吧.

注意:由于宝藏的历史久远,当时的系统最多只能保存500位密码.因此如果得到的密码长度大于500也不能用来开启房门,这种情况也被认为密码不存在.
 

Input
输入数据的第一行是一个整数T(1<=T<=300),表示测试数据的数量.每组测试数据的第一行是两个整数N(0<=N<=5000)和C(2<=C<=16),其中N表示的是题目描述中的给定十进制整数,C是密码的进制数.测试数据的第二行是一个整数M(1<=M<=16),它表示构成密码的数字的数量,然后是M个数字用来表示构成密码的数字.两个测试数据之间会有一个空行隔开.

注意:在给出的M个数字中,如果存在超过10的数,我们约定用A来表示10,B来表示11,C来表示12,D来表示13,E来表示14,F来表示15.我保证输入数据都是合法的.
 

Output
对于每组测试数据,如果存在要求的密码,则输出该密码,如果密码不存在,则输出"give me the bomb please".

注意:构成密码的数字不一定全部都要用上;密码有可能非常长,不要试图用一个整型变量来保存密码;我保证密码最高位不为0(除非密码本身就是0).
 

Sample Input
3 22 10 3 7 0 1 2 10 1 1 25 16 3 A B C
 

Sample Output
110 give me the bomb please CCB
Hint
Hint
Huge input, scanf is recommended.
 余数判重。
152%n=(100+(50+2%n)%n)%n。
代码:
#include <cstdio>
#include <string>
#include <queue>
#include <cstring>
#include <iostream>

using namespace std ;

struct Node{
	string ans;
	int mod ;
};
int n , c , m ;
bool t[20] , visited[5500] , flag = false ;
string ans ;
void BFS()
{
	Node now ;
	queue <Node> que ;
	for(int i = 1 ; i < 16 ; ++i)
	{
		if(t[i])
		{
			now.ans.clear() ;
			if(i<10)
				now.ans += i+'0' ;
			else
				now.ans += i-10+'A' ;
			now.mod = i%n ;
			que.push(now) ;
			visited[i%n] == true ;
		}
	}
	flag = false ;
	while(!que.empty())
	{
		now = que.front() ;
		que.pop() ;
		if(flag && now.ans.size()>ans.size())
			continue ;
		if(now.mod == 0)
		{
			if(!flag)
			{
				ans = now.ans ;
				flag = true ;
			}
			if(ans.size()>now.ans.size() || (ans.size()==now.ans.size()&&ans>now.ans))
			{
				ans = now.ans ;
			}
			continue ;
		}
		for(int i = 0 ; i < 16 ; ++i)
		{
			if(t[i])
			{
				Node next = now ;
				if(i<10)
				{
					next.ans += i+'0' ;
				}
				else
				{
					next.ans += i-10+'A' ;
				}
				next.mod = (next.mod*c+i)%n ;
				if((next.ans.size()<=500 && !visited[next.mod])||next.mod==0 )
				{
					que.push(next) ; 
					visited[next.mod] = true ;
				}
			}
		}
	}
}

int main()
{
	int T ;
	scanf("%d",&T) ;
	while(T--)
	{
		scanf("%d%d",&n,&c) ;
		scanf("%d",&m) ;
		getchar() ;
		memset(t,false,sizeof(t)) ;
		for(int i = 0 ; i < m ; ++i )
		{
			char ch ;
			scanf("%c",&ch) ;
			if(ch>='0'&&ch<='9')
				t[ch-'0'] = true ;
			else
				t[ch-'A'+10] = true ;
			getchar() ;
		}
		memset(visited,false,sizeof(visited)) ;
		ans.clear() ;
		if(n == 0)
		{
			if(t[0])
				cout<<0<<endl ;
			else
				cout<<"give me the bomb please"<<endl ;
			continue ;
		}
		flag = false ;
		BFS() ;
		if(!flag)
			cout<<"give me the bomb please"<<endl ;
		else
			cout<<ans<<endl ;
	}
	return 0 ;
}

与君共勉

hdu 1226 超级密码 BFS 挺不错的题啊!

标签:hdu1226   超级密码   bfs   

原文地址:http://blog.csdn.net/lionel_d/article/details/44924989

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!