码迷,mamicode.com
首页 > 其他好文 > 详细

蚂蚁问题poj1852

时间:2015-04-07 23:21:55      阅读:181      评论:0      收藏:0      [点我收藏+]

标签:

蚂蚁问题poj1852

蚂蚁问题poj1852

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

错误:

使用 cin和cout去输入和输出,超时....
// CreateTime: 2015-04-07 22:33:03

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>

using namespace std;

const int maxn = 1000005;
int l;
int n;
int a[maxn];

int main(void) {
    int t;
    scanf("%d", &t);
    while(t--) {
        scanf("%d%d", &l, &n);
        for (int i = 0; i < n; i++) {
            scanf("%d", &a[i]);
        }

        int minT = 0;
        for (int i = 0; i < n; i++) {
            minT = max(minT, min(a[i], l-a[i]));
        }

        int maxT = 0;
        for (int i = 0; i < n; i++) {
            maxT = max(maxT, max(a[i], l-a[i]));
        }

        printf("%d %d\n", minT, maxT);
    }
    return 0;
}

蚂蚁问题poj1852

标签:

原文地址:http://www.cnblogs.com/sunznx/p/4399876.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!