码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU ACM 1720 A+B Coming

时间:2015-04-08 09:17:56      阅读:117      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   算法   编程   杭电   



A+B Coming

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6464    Accepted Submission(s): 4248


Problem Description
Many classmates said to me that A+B is must needs.
If you can’t AC this problem, you would invite me for night meal. ^_^
 

Input
Input may contain multiple test cases. Each case contains A and B in one line.
A, B are hexadecimal number.
Input terminates by EOF.
 

Output
Output A+B in decimal number in one line.
 

Sample Input
1 9 A B a b
 

Sample Output
10 21 21
 
这个题无语……表示以前见过 但是忘了!!
知识一:
将十六进制转换为十进特例:
AB转换为dec;
0xAB
= 0x0A * 16 + 0x0B
= 10 * 16 + 11
= 171

c 输入十六进制和八进制方法:
scanf(“%x %x”,&a,&b);
scanf(“%o %o”,&a,&b);

c++ 方法:
cin>>hex>>a>>b;
cin>>oct>>a>>b;
输出与之类似 ,

败了 看来要请吃饭了!
AC:
#include<iostream>
using namespace std;
int main()
{
	int a,b;
	while(cin>>hex>>a>>b)
	  cout<<dec<<a+b<<endl;
return 0;
}


杭电 HDU ACM 1720 A+B Coming

标签:acm   c++   算法   编程   杭电   

原文地址:http://blog.csdn.net/lsgqjh/article/details/44926311

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!