码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2069 Coin Change 背包。本来打算用母函数再写一遍的,发现代码极其相似,就没写

时间:2015-04-08 16:35:21      阅读:132      评论:0      收藏:0      [点我收藏+]

标签:hdu2069   coin change   dp   完全背包   

Coin Change

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14982    Accepted Submission(s): 5070


Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
 

Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
 

Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
 

Sample Input
11 26
 

Sample Output
4 13
 

Author
Lily
 

Source
 
由于最多只能用100枚硬币,所以数组得再加一维
dp[i][j]代表的是总额为i需要j枚硬币。
dp[i][j] = dp[i-v][j-1] ;
代码;
#include <stdio.h>
#include <string.h>
#define MAX 300
#define COUNT 100

const int type[]={50,25,10,5,1} ;
int dp[MAX][110] ;
int max(int a , int b)
{
	return a>b?a:b ;
}
int main() 
{
	dp[0][0] = 1 ;
	for(int i = 0 ; i < 5 ; ++i)
	{
		for(int j = type[i] ; j <= 250 ; ++j)
		{
			for(int m = 0 ; m < 100 ; ++m)
			{
					dp[j][m+1] += dp[j-type[i]][m] ;
			}	
		}
	}
	int n ;
	while(~scanf("%d",&n))
	{
		int ans = 0 ;
		for(int i = 0 ; i <= 100 ; ++i)
			ans += dp[n][i] ;
		printf("%d\n",ans) ;
	}
	return 0 ;
}

与君共勉

hdu 2069 Coin Change 背包。本来打算用母函数再写一遍的,发现代码极其相似,就没写

标签:hdu2069   coin change   dp   完全背包   

原文地址:http://blog.csdn.net/lionel_d/article/details/44941257

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!