码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ-2199-Can you solve this equation?(二分查找)

时间:2015-04-09 08:51:31      阅读:108      评论:0      收藏:0      [点我收藏+]

标签:

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11044    Accepted Submission(s): 5083


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
2 100 -4
 

Sample Output
1.6152 No solution!
 

Author
Redow

#include<stdio.h>
#include<math.h>
double f(double x){
	return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
double binary_search(double x,double y,double n){
	double mid=(x+y)/2;
	if(y-x<=1e-7)	return x;   //刚开始写成 if(fabs(n-f(mid))<=1e-7) return mid; 结果超时,原来还是没理解透二分查找的具体退出边界条件!!!
	else if(f(mid)>=n) return binary_search(x,mid+1e-20,n);   //错了n遍,写成了mid+1e-7!!!
	else return binary_search(mid+1e-20,y,n);	    
}
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		double y,t;
		scanf("%lf",&y);
        if(y<f(0)||y>f(100)){
        	printf("No solution!\n");
        	continue;
        }
		t=binary_search(0,100,y);
		printf("%.4lf\n",t);
	}
	return 0;
}


HDOJ-2199-Can you solve this equation?(二分查找)

标签:

原文地址:http://blog.csdn.net/qq_18062811/article/details/44949041

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!