码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2478-Farey Sequence(筛选法求欧拉函数)

时间:2015-04-09 09:00:19      阅读:157      评论:0      收藏:0      [点我收藏+]

标签:

Farey Sequence
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

题意:给定一个数n,求小于或等于n的数中两两互质组成的真分数的个数。

思路:这个博客有关于这道题的推理---->点击打开链接

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
const double pi= acos(-1.0);
LL phi[1000010];
LL res[1000010];
void Euler()
{
    int i,j;
    memset(phi,0,sizeof(phi));
    phi[1]=1;
    for(i=2;i<=1000010;i++)
    {
        if(!phi[i])
        {
            for(j=i;j<=1000010;j+=i)
            {
                if(!phi[j]) 
                    phi[j]=j;
                phi[j]=phi[j]/i*(i-1);
            }
        }
    }
}
int main()
{
    int n;
    Euler();
    memset(res,0,sizeof(res));
    res[1]=res[2]=1;
    for(int i=3;i<1000010;i++)
        res[i]=res[i-1]+phi[i];
    while(~scanf("%d",&n)){
        if(!n) break;
        printf("%lld\n",res[n]);
    }
    return 0;
}


POJ 2478-Farey Sequence(筛选法求欧拉函数)

标签:

原文地址:http://blog.csdn.net/u013486414/article/details/44946023

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!