码迷,mamicode.com
首页 > 其他好文 > 详细

深搜 nyoj 43 24 Point game

时间:2015-04-09 17:38:33      阅读:119      评论:0      收藏:0      [点我收藏+]

标签:深搜

24 Point game

时间限制:3000 ms  |  内存限制:65535 KB
难度:5
描述

There is a game which is called 24 Point game.

In this game , you will be given some numbers. Your task is to find an expression which have all the given numbers and the value of the expression should be 24 .The expression mustn‘t have any other operator except plus,minus,multiply,divide and the brackets. 

e.g. If the numbers you are given is "3 3 8 8", you can give "8/(3-8/3)" as an answer. All the numbers should be used and the bracktes can be nested. 

Your task in this problem is only to judge whether the given numbers can be used to find a expression whose value is the given number。

输入
The input has multicases and each case contains one line
The first line of the input is an non-negative integer C(C<=100),which indicates the number of the cases.
Each line has some integers,the first integer M(0<=M<=5) is the total number of the given numbers to consist the expression,the second integers N(0<=N<=100) is the number which the value of the expression should be.
Then,the followed M integer is the given numbers. All the given numbers is non-negative and less than 100
输出
For each test-cases,output "Yes" if there is an expression which fit all the demands,otherwise output "No" instead.
样例输入
2
4 24 3 3 8 8
3 24 8 3 3
样例输出
Yes
No
来源
经典改编
上传者

张云聪


题目不难,只有四种可能,逐个遍历搜索就行!

代码如下:

//考查知识点:深搜
//因为全角,半角的输入问题,看了一个小时。。。 
#include<stdio.h>
#include<math.h>
#include<string.h>
#define eps 10E-6
int n;
double sum;
double a[110];
int dfs(int num)
{
	if(num==n)
	{
		if(fabs(a[n]-sum)<=eps)//跳出条件 
		return 1;
		return 0;
	}
	for(int i=num;i<n;++i)//从num开始保证了深度遍历的时候,数字逐步后移 
	{
		for(int j=i+1;j<=n;++j)
		{
			double right,left;
			left=a[i];
			right=a[j];
			a[i]=a[num];//将值赋值给数组 
			
			a[j]=left+right;//遍历每一种可能的操作 
			if(dfs(num+1))
			return 1;
			
			a[j]=left-right;//大小不确定 
			if(dfs(num+1))
			return 1;
			
			a[j]=-left+right;
			if(dfs(num+1))
			return 1;
			
			a[j]=left*right;
			if(dfs(num+1))
			return 1;
			
			if(right)
			a[j]=left/right;//除数不为零 
			if(dfs(num+1))
			return 1;
			
			if(left)
			a[j]=right/left;
			if(dfs(num+1))
			return 1;
			
			a[i]=left;//回溯 
			a[j]=right;
		}
	}
	return 0;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%lf",&n,&sum);
		for(int i=1;i<=n;++i)
		{
			scanf("%lf",&a[i]);
		}
		if(dfs(1))
		puts("Yes");
		else
		puts("No");
	}
	return 0;
} 


深搜 nyoj 43 24 Point game

标签:深搜

原文地址:http://blog.csdn.net/ice_alone/article/details/44960597

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!