标签:kmp acm算法 algorithm amp cstring
Oulipo
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5931 Accepted Submission(s): 2383
Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
Source
题意:
求模式串在子串出现的次数。
跑个KMP就好了,,
#include <stdio.h>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
using namespace std;
#define mod 1000000007
#define inf 0x7f7f7f7f
int Next[10005];
char w[10005];
char t[1000005];
int lenw,lent;
int ans;
void GetNext()
{
int i=0;
int j=-1;
Next[i]=j;
while(i<lenw)
{
if(j==-1 || w[i]==w[j])
{
i++;
j++;
Next[i]=j;
}
else
j=Next[j];
}
}
void kmp()
{
int i=0;
int j=0;
while(i<lent)
{
if(j==-1 ||t[i]==w[j])
{
i++;
j++; //匹配一个j+1;
}
else
j=Next[j];
if(j>=lenw) //直到匹配lenw个。。
{
ans++; //出现的次数加一。。
j=Next[j];
}
}
}
int main()
{
int n;
cin>>n;
while(n--)
{
ans=0;
scanf("%s%s",w,t);
lenw=strlen(w);
lent=strlen(t);
if(lenw>lent)
{
cout<<0<<endl;
continue;
}
GetNext();
kmp();
cout<<ans<<endl;
}
return 0;
}
HDU 1686 Oulipo
标签:kmp acm算法 algorithm amp cstring
原文地址:http://blog.csdn.net/sky_miange/article/details/44964885