码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1228 A + B (水题)

时间:2015-04-10 22:30:29      阅读:126      评论:0      收藏:0      [点我收藏+]

标签:hdu

A + B

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13260 Accepted Submission(s): 7797


Problem Description
读入两个小于100的正整数A和B,计算A+B.
需要注意的是:A和B的每一位数字由对应的英文单词给出.

Input
测试输入包含若干测试用例,每个测试用例占一行,格式为"A + B =",相邻两字符串有一个空格间隔.当A和B同时为0时输入结束,相应的结果不要输出.

Output
对每个测试用例输出1行,即A+B的值.

Sample Input
one + two = three four + five six = zero seven + eight nine = zero + zero =

Sample Output
3 90 96
水题。
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
typedef __int64 ll;

char str[11][10]={"zero","one","two","three","four","five","six","seven","eight","nine"};

char s[20];

int main()
{
	int res,i,j,n,sum,fact1,fact2,ans;
	while(scanf("%s",s)!=EOF){
		fact1=fact2=0;
		for(i=0;i<10;i++)
			if(strcmp(s,str[i])==0)
				break;
		fact1=i;
		while(scanf("%s",s)){
			if(s[0]==' ') continue;
			if(s[0]=='+') break;
			for(i=0;i<10;i++)
			if(strcmp(s,str[i])==0)
				break;
			fact1=fact1*10+i;
		}
		while(scanf("%s",s)){
			if(s[0]==' ') continue;
			if(s[0]=='=') break;
			for(i=0;i<10;i++)
			if(strcmp(s,str[i])==0)
				break;
			fact2=fact2*10+i;
		}
		if(fact1==0 && fact2==0)
			break;
		printf("%d\n",fact1+fact2);
	}
	return 0;
}


HDU 1228 A + B (水题)

标签:hdu

原文地址:http://blog.csdn.net/u013068502/article/details/44983993

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!