码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2503 Babelfish(字典树)

时间:2015-04-10 22:30:18      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:poj   数据结构   

Babelfish
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 35009   Accepted: 14979

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

纯字典树水题。
学到的知识:
① sscanf 函数,scanf函数的兄弟,把字符串按指定格式读入到指定变量。
② Node 节点置空,可以不用NULL,而是用0更简洁安全。

/*
Trie(字典树)
*/
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
typedef __int64 ll;

typedef struct Node{
	char word[15];
	struct Node *ch[27];	//没想到ch[]的初值可以为0,一开始我用NULL异常退出了
}node;

node *T;
int index;

void add(char s[],char wd[]){
	node *u;
	u=T;
	int len=strlen(s),i;

	for(i=0;i<len;i++){
		if(u->ch[s[i]-'a']==0){
			node *t=(node*)malloc(sizeof(node));
			for(int j=0;j<27;j++)
				t->ch[j]=0;
			u->ch[s[i]-'a']=t;
		}
		u=u->ch[s[i]-'a'];
	}
	strcpy(u->word,wd);
}

void ask(char s[]){
	node* u=T;
	int i,len=strlen(s);
	for(i=0;i<len;i++){
		if(u==0){
			printf("eh\n");
			return ;
		}
		else 
			u=u->ch[s[i]-'a'];
	}
	printf("%s\n",u->word);
}


int main()
{
	int i,k,j;
	char s1[20],s2[20],str[50];
	T=(node*)malloc(sizeof(node));
	for(i=0;i<27;i++)
		T->ch[i]=0;
	while(gets(str)){
		if(str[0]=='\0') break;
		sscanf(str,"%s %s",s1,s2);		//需要借助sscanf来处理
		add(s2,s1);
	}
	while(scanf("%s",s1)!=EOF){
		ask(s1);
	}
	return 0;
}


POJ 2503 Babelfish(字典树)

标签:poj   数据结构   

原文地址:http://blog.csdn.net/u013068502/article/details/44983843

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!