码迷,mamicode.com
首页 > 其他好文 > 详细

uva 101 The Blocks Problem (基本算法-模拟)

时间:2014-06-08 15:49:01      阅读:220      评论:0      收藏:0      [点我收藏+]

标签:c   style   class   blog   code   a   



  The Blocks Problem 

Background 

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.

In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program‘‘ a robotic arm to respond to a limited set of commands.

The Problem 

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1 for all bubuko.com,布布扣 as shown in the diagram below:
 
bubuko.com,布布扣
Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:

  • move a onto b

    where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.

  • move a over b

    where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.

  • pile a onto b

    where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved.

  • pile a over b

    where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block aretain their original order when moved.

  • quit

    terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

The Input 

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25.

The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

The Output 

The output should consist of the final state of the blocks world. Each original block position numbered i (bubuko.com,布布扣 where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don‘t put any trailing spaces on a line.

There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

Sample Input 

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output 

 0: 0
 1: 1 9 2 4
 2:
 3: 3
 4:
 5: 5 8 7 6
 6:
 7:
 8:
 9:



Miguel Revilla 
2000-04-06

题目大意:

问题就是分析一系列的命令,告诉机械臂如何操纵放在一个平台上的积木。最初平台上有n个积木(编号由0到n - 1),对于任意的0 ≤ i < n - 1,积木bi都与bi + 1相临
机械臂操作积木的有效指令列举如下:
(1)move a onto b
a和b都是积木的编号,先将a和b上面所有的积木都放回原处,再将a放在b上。
(2)move a over b
a和b都是积木的编号,先将a上面所有的积木放回原处,再将a放在b上。(b上原有积木不动)
(3)pile a onto b
a和b都是积木的编号,将a和其上面所有的积极组成的一摞整体移动到b上。在移动前要先将b上面所有的积极都放回原处。移动的一摞积木要保持原来的顺序不变。
(4)pile a over b
a和b都是积木的编号,将a和其上面所有的积极组成的一摞整体移动到b所在一摞积木的最上面一个积木上。移动的一摞积木要保持原来的顺序不变。
(5)quit
结束积木世界的操纵。

注意:当a = b或a和b处在同一摞时,任何企图操作a和b的命令都是非法的。所有非法的命令都要忽略,且不能对当前积木的状态产生作用。

最后,让你输出各个位置的样子


解题思路:

很简单的题目,在理解题意的基础上,用合适的数据结构记录就好,我是记录每个积木的二维坐标位置,以及当前积木的情况。维护好这两个记录,就能轻松模拟。


解题代码:

#include <iostream>
#include <cstdio>
#include <vector>
#include <string>
#include <sstream>
#include <cstdlib>
using namespace std;

vector < vector<int> > v;
vector < pair<int,int> > pos;
int n;

void initial(){
    pos.clear();
    v.clear();
    pos.resize(n);
    v.resize(n);
    for(int i=0;i<n;i++){
        pos[i]=make_pair(i,0);
        v[i].push_back(i);
    }
}

void getini(int s){
    int x=pos[s].first,y=pos[s].second;
    while(v[x].size()>y+1){
        int d=v[x].back();
        v[x].pop_back();
        pos[d]=make_pair(d,v[d].size());
        v[d].push_back(d);
    }
}

void moveTo(int a,int b){
    int xa=pos[a].first,ya=pos[a].second,xb=pos[b].first;
    for(int i=ya;i<v[xa].size();i++){
        int d=v[xa][i];
        pos[d]=make_pair(xb,v[xb].size());
        v[xb].push_back(d);
    }
    while(v[xa].size()>ya){
        v[xa].pop_back();
    }
}

void solve(){
    int a,b;
    string op1,op2,st;
    while(getline(cin,st) && st!="quit"){
        stringstream ss(st);
        ss>>op1>>a>>op2>>b;
        if(pos[a].first==pos[b].first) continue;
        if(op1=="move"){
            if(op2=="onto"){
                getini(a);
                getini(b);
                moveTo(a,b);
            }else{
                getini(a);
                moveTo(a,b);
            }
        }else{
            if(op2=="onto"){
                getini(b);
                moveTo(a,b);
            }else{
                moveTo(a,b);
            }
        }

    }
    for(int i=0;i<n;i++){
        printf("%d:",i);
        for(int j=0;j<v[i].size();j++){
            printf(" %d",v[i][j]);
        }
        printf("\n");
    }
}

int main(){
    while(scanf("%d\n",&n)!=EOF){
        initial();
        solve();
    }
    return 0;
}


uva 101 The Blocks Problem (基本算法-模拟),布布扣,bubuko.com

uva 101 The Blocks Problem (基本算法-模拟)

标签:c   style   class   blog   code   a   

原文地址:http://blog.csdn.net/a1061747415/article/details/28886243

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!