码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4027—— Can you answer these queries?——————【线段树区间开方,区间求和】

时间:2015-04-11 20:41:24      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:

Can you answer these queries?
Time Limit:2000MS     Memory Limit:65768KB     64bit IO Format:%I64d & %I64u

Description

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help. 
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line. 

Notice that the square root operation should be rounded down to integer.
 

Input

The input contains several test cases, terminated by EOF. 
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000) 
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000) 
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive. 
 

Output

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input

10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output

Case #1: 19 7 6
 
 
 
解题思路:刚开始看到题目的时候感觉蛮简单的,就是类似区间增减的感觉。但是慢慢写着写着感觉没法写了。于是就看了看网上别人的思路,发现原来平方藏有玄机。2^64如果要开方的话,最多也就开7次,所以如果对区间标记是否有结点仍能开方,就能省下很多的更新时间,如果能开方,就找到叶子结点进行开方操作,同时更新路径上的sumv数组和num数组,而询问就是简单的区间求和了。
 
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define mid (L+R)/2
#define lson rt*2,L,mid
#define rson rt*2+1,mid+1,R
#define LL long long
const int maxn=101000;
LL sumv[maxn*4];
int num[maxn*4];
void PushUP(int rt){
    sumv[rt]=sumv[rt*2]+sumv[rt*2+1];
    num[rt]=num[rt*2]+num[rt*2+1];
}
void build(int rt,int L,int R){
    if(L==R){
        scanf("%lld",&sumv[rt]);
        if(sumv[rt]==0||sumv[rt]==1){
            num[rt]=0;
        }else{
            num[rt]=1;
        }
        return ;
    }
    build(lson);
    build(rson);
    PushUP(rt);
}
void _sqrt(int rt,int L,int R){
    if(L==R){
        sumv[rt]=(LL)sqrt(sumv[rt]);
        if(sumv[rt]==0||sumv[rt]==1){
            num[rt]=0;
        }else{
            num[rt]=1;
        }
        return ;
    }
    _sqrt(lson);
    _sqrt(rson);
    PushUP(rt);
}
void update(int rt,int L,int R,int l_ran,int r_ran){
    if(l_ran<=L&&R<=r_ran){
        if(num[rt]!=0){
            _sqrt(rt,L,R);
        }
        return ;
    }
    if(l_ran<=mid){
        update(lson,l_ran,r_ran);
    }
    if(r_ran>mid){
        update(rson,l_ran,r_ran);
    }
    PushUP(rt);
}
LL query(int rt,int L,int R,int l_ran,int r_ran){
    if(l_ran<=L&&R<=r_ran){
        return sumv[rt];
    }
    LL ret=0;
    if(l_ran<=mid){
        ret+=query(lson,l_ran,r_ran);
    }
    if(r_ran>mid){
        ret+=query(rson,l_ran,r_ran);
    }
    return ret;
}
int main(){
    int n,m,cnt=0;
    while(scanf("%d",&n)!=EOF){
        build(1,1,n);
        printf("Case #%d:\n",++cnt);
        scanf("%d",&m);
        for(int i=0;i<m;i++){
            int f,tml,tmr;
            scanf("%d%d%d",&f,&tml,&tmr);
            if(tml>tmr){
                int k=tml;
                tml=tmr;
                tmr=k;
            }
            if(!f){
                update(1,1,n,tml,tmr);
            }else{
                printf("%lld\n",query(1,1,n,tml,tmr));
            }
        }
        printf("\n");
    }
    return 0;
}

  

HDU 4027—— Can you answer these queries?——————【线段树区间开方,区间求和】

标签:

原文地址:http://www.cnblogs.com/chengsheng/p/4418324.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!