码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 540 Team Queue(STL,队列 )

时间:2015-04-12 09:12:21      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

技术分享

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.


In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.


Your task is to write a program that simulates such a team queue.

Input 

The input file will contain one or more test cases. Each test case begins with the number of teams t ( 技术分享). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

  • ENQUEUE x - enter element x into the team queue
  • DEQUEUE - process the first element and remove it from the queue
  • STOP - end of test case

The input will be terminated by a value of 0 for t.


Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

Output 

For each test case, first print a line saying `` Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

Sample Input 

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output 

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001



Miguel A. Revilla
1999-01-11

t个团队的人在排一个长队,新来一个人时,如果有他的队友在排队,那么新来的人就会插队到最后一个队友的身后,否则排在长队的队尾。

有三种指令:

ENQUEUE x:编号为x的人进入长队。

DEQUEUE:长队的队首出列。

STOP:停止模拟。

思路:用两个queue来记录长队的排列情况。

#include<iostream>
#include<cstdio>
#include<queue>
#include<string>
#include<map>
using namespace std;
int main()
{
	int cas=0;
	int t;
	while (scanf("%d", &t) != EOF&&t)
	{
		cout << "Scenario #" << ++cas << endl;
		int n, x;
		map<int, int>team;  //记录所有人的团队编号,team[x]表示编号为x的人所在的团队编号。
		for (int i = 0; i < t; i++)
		{
			cin >> n;
			while (n--)
			{
				cin >> x;
				team[x] = i; 
			}
		}
	
		string op;  int num;
		queue<int>teamate[1010];  //各个团队的成员的队列
		queue<int>teamm;  //团队的队列
		for (;;)
		{
			cin >> op;
			if (op[0] == 'S') break;
			if (op[0] == 'E')
			{
				cin >> num;
				if (teamate[team[num]].empty()) teamm.push(team[num]);  //新团队入队
				teamate[team[num]].push(num);
			}
			if (op[0] == 'D')
			{
				int temp = teamm.front();
				cout << teamate[temp].front() << endl; 
				teamate[temp].pop();
				if (teamate[temp].empty()) teamm.pop();  //长队中已经没有该队的人
			}
		}	
		cout << endl;
	}
}



UVA - 540 Team Queue(STL,队列 )

标签:

原文地址:http://blog.csdn.net/qq_18738333/article/details/45006089

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!