码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 12096 The SetStack Computer(编码,STL)

时间:2015-04-12 09:13:00      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:

12096 The SetStack Computer
Background from Wikipedia: “Set theory is a branch of mathematics created principally by the German mathe-matician Georg Cantor at the end of the 19th century.Initially controversial, set theory has come to play the role of a foundational theory in modern mathematics,in the sense of a theory invoked to justify assumptions made in mathematics concerning the existence of mathe-matical objects (such as numbers or functions) and their properties. Formal versions of set theory also have a foundational role to play as specifying a theoretical ideal of mathematical rigor in proofs.” Given this importance of sets, being the basis of mathematics, a set of eccentric theorist set off to construct a supercomputer operating on sets in-stead of numbers. The initial SetStack Alpha is under construction, and they need you to simulate it in order to verify the operation of the prototype. The computer operates on a single stack of sets, which is initially empty. After each operation, the cardinality of the topmost set on the stack is output. The cardinality of a set S is denoted |S| and is the number of elements in S. The instruction set of the SetStack Alpha is PUSH, DUP, UNION, INTERSECT,and ADD.

? PUSH will push the empty set {} on the stack.
? DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).
? UNION will pop the stack twice and then push the union of the two sets on the stack.
? INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.
? ADD will pop the stack twice, add the first set to the second one, and then push the resulting set
on the stack.

For illustration purposes, assume that the topmost element of the stack is
A = {{},{{}}}
and that the next one is
B = {{},{{{}}}}
For these sets, we have |A| = 2 and |B| = 2. Then:
? UNION would result in the set {{}, {{}}, {{{}}}}. The output is 3.
? INTERSECT would result in the set {{}}. The output is 1.
? ADD would result in the set {{}, {{{}}}, {{},{{}}}}. The output is 3.

Input
An integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of eachtest case contains the number of operations 0 ≤ N ≤ 2000. Then follow N lines each containing one of the five commands. It is guaranteed that the SetStack computer can execute all the commands in the sequence without ever popping an empty stack.
Output
For each operation specified in the input, there will be one line of output consisting of a single integer. This integer is the cardinality of the topmost element of the stack after the corresponding command has executed. After each test case there will be a line with ‘***’ (three asterisks).


Sample Input
2
9
PUSH
DUP
ADD
PUSH
ADD
DUP
ADD
DUP
UNION
5
PUSH
PUSH
ADD
PUSH
INTERSECT


Sample Output
0
0
1
0
1
1
2
2
2
***
0
0
1
0
0
***

题目大意:集合的运算
有5种操作:

PUSH: 空集“{}”入栈。

DUP:把当前栈顶元素复制一份后再入栈。

UNION:出栈两个集合,然后把二者的并集入栈。

INTERSECT:出栈两个集合,然后把二者的交集入栈

ADD:出栈两个集合,然后把先出栈的加入到后出栈的集合中,把结果入栈。

每次操作后输出栈顶集合的大小。

是集合的集合,为了表示不同的集合,可用一个整型ID表示,比如说用1表示{},集合{{}}就表示成{1},再用2作为其ID。于是题目就成了编码问题,对每个新生成的集合,我们判断该集合是否出现过,若未出现过,就给他分配一个新的ID,出现过的用已有的ID表示。所有集合用map表示集合与ID的对应关系,用一个队列存集合,以便根据ID去集合。

#include<iostream>
#include<set>
#include<vector>
#include<stack>
#include<map>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;

#define ALL(x) x.begin(),x.end()         //表示所有的内容
#define INS(x) inserter(x,x.begin())     //插入迭代器

typedef set<int> Set;
map<Set, int>IDcache;    //把集合映射成ID
vector<Set>Setcache;     //根据ID取集合

//查找给定集合x的ID。如果找不到,分配一个新的ID
int ID(Set x)
{
	if (IDcache.count(x))return IDcache[x];
	Setcache.push_back(x);  //添加新集合
	return IDcache[x] = Setcache.size() - 1;
}

int main()
{
	int casen;
	cin >> casen;
	while (casen--)
	{
		IDcache.clear();
		Setcache.clear();
		stack<int>s;   //集合栈
		int n;
		cin >> n;
		for (int i = 0; i < n; i++)
		{
			string op;
			cin >> op;
			if (op[0] == 'P') s.push(ID(Set()));
			else if (op[0] == 'D') s.push(s.top());
			else
			{
				Set x1 = Setcache[s.top()]; s.pop();
				Set x2 = Setcache[s.top()]; s.pop();
				Set x;
				if (op[0] == 'U') set_union(ALL(x1), ALL(x2), INS(x));
				if (op[0] == 'I') set_intersection(ALL(x1), ALL(x2), INS(x));
				if (op[0] == 'A') { x = x2; x.insert(ID(x1)); }
				s.push(ID(x));
			}
			cout << Setcache[s.top()].size() << endl;
		}
		cout << "***" << endl;
	}
}


UVA - 12096 The SetStack Computer(编码,STL)

标签:

原文地址:http://blog.csdn.net/qq_18738333/article/details/45004113

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!