码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 11464 - Even Parity

时间:2015-04-12 09:15:39      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:acm   uva   

11464 Even Parity
We have a grid of size N × N. Each cell of the grid initially contains a zero(0) or a one(1). The parity
of a cell is the number of 1s surrounding that cell. A cell is surrounded by at most 4 cells (top, bottom,
left, right).
Suppose we have a grid of size 4 × 4:
1 0 1 0 The parity of each cell would be 1 3 1 2
1 1 1 1 2 3 2 1
0 1 0 0 2 1 2 1
0 0 0 0 0 1 0 0
For this problem, you have to change some of the 0s to 1s so that the parity of every cell becomes
even. We are interested in the minimum number of transformations of 0 to 1 that is needed to achieve
the desired requirement.

Input
The ?rst line of input is an integer T (T < 30) that indicates the number of test cases. Each case starts
with a positive integer N (1 ≤ N ≤ 15). Each of the next N lines contain N integers (0/1) each. The
integers are separated by a single space character.

Output
For each case, output the case number followed by the minimum number of transformations required.
If it’s impossible to achieve the desired result, then output ‘-1’ instead.

Sample Input
3
3
0 0 0
0 0 0
0 0 0
3
0 0 0
1 0 0
0 0 0
3
1 1 1
1 1 1
0 0 0

Sample Output
Case 1: 0
Case 2: 3
Case 3: -1



AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define INF 0x7fffffff
using namespace std;

const int maxn = 20;

int n, a[maxn][maxn], b[maxn][maxn];

int check(int x) {
	memset(b, 0, sizeof(b));
	for(int i = 0; i < n; i++) {
		if(x & (1 << i)) b[0][i] = 1;
		else if(a[0][i] == 1) return INF;//冲突 
	}
	
	for(int i = 1; i < n; i++) {
		for(int j = 0; j < n; j++) {
			int sum = 0;
			if(i > 1) sum += b[i-2][j];
			if(j > 0) sum += b[i-1][j-1];
			if(j < n - 1) sum += b[i-1][j+1];
			b[i][j] = sum % 2;
			if(a[i][j] == 1 && b[i][j] == 0) return INF;
		}
	}
	
	int cnt = 0;
	for(int i = 0; i < n; i++) {
		for(int j = 0; j < n; j++) {
			if(a[i][j] != b[i][j]) cnt++;
		}
	}
	return cnt;
}

int main() {
	int T;
	scanf("%d", &T);
	for(int cas = 1; cas <= T; cas++) {
		scanf("%d", &n);
		for(int i = 0; i < n; i ++) {
			for(int j = 0; j < n; j ++) {
				scanf("%d", &a[i][j]);
			}
		}
		
		int ans = INF;
		for(int i = 0; i < (1 << n); i ++) {
			ans = min(ans, check(i));
		}
		
		if(ans == INF) ans = -1;
		printf("Case %d: %d\n", cas, ans);
	}
	return 0;
}













UVA - 11464 - Even Parity

标签:acm   uva   

原文地址:http://blog.csdn.net/u014355480/article/details/45000923

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!